locked
ORA-03134: Connections to this server version are no longer supported. RRS feed

  • Question

  • When attempting to connect to an Oracle database version 8.1.7.4 I am getting the error: ORA-03134: Connections to this server version are no longer supported. However, I do not when connecting to Oracle database version 9.2.0.7. I have downloaded and installed the most current Oracle data provider.  I do need the ability to connect to both version (8.1.7.4 and 9.2.0.7) Any Suggestions?

     

    Friday, March 26, 2010 7:02 PM

All replies

  • I've had some trouble along these lines with the Oracle ODBC components.  Major version changes seem to be dramatic - to the point of inoperability as you pointed out.

    Have you tried the .net Oracle data access classes?  (http://msdn.microsoft.com/en-us/library/system.data.oracleclient.aspx) There may be some small performance issues and some specific circumstances are not fully supported, but for normal DML-type sql this should work ok. 

    Another alternative is to get the older ODP components and reference both versions from your app.  A cleaner implementation might be through system dsn's where the driver is mapped outside of your code.

    The ODP.net components have the same trouble through version 10 and into the 64 bit 1.x and 2.x versions.

    Monday, March 29, 2010 7:59 PM