locked
Connection to Android Device not possible - How to solve it? RRS feed

  • Question

  • User387183 posted

    Hello everybody, I am new to the forum and have a little problem. I am trying to connect wireless to my android device. I can connect to it via adb and it shows up in the adb list (when I run "adb devices"), but it does not show up in the device selection menu to debug to the device... Can anyone help me out?

    Thank you very much!

    Sunday, July 7, 2019 7:39 PM

All replies

  • User383585 posted

    Open command prompt with 'run as administrator'. Connect your mobile device to your computer with usb cable. Navigate to Android installation folder in command prompt using the following command,"cd C:\Program Files (x86)\Android\android-sdk\platform-tools" Type "adb tcpip 5555" command. Find out the IP address of your mobile device and type "adb connect ". Type "adb devices" and it will return this.

    List of devices attached, ipaddress:5555 device

    adb usb adb tcpip 5555 adb connect

    Tuesday, July 9, 2019 11:11 AM
  • User387183 posted

    Thank you for your answer.

    I already did this steps and tried it again. As I said, I can connect to the device via ADB. When I run "adb devices", it shows up.

    The problem is, that visual studio does not show it up in the device selection menu to debug to it.

    The "Xamarin Diagnostic" output said something with "Adb shell: 192.168.178.4:5555 getprop" (I don't remember exactly, next time I post the original output).

    Can someone help?

    Wednesday, July 10, 2019 7:26 PM