locked
Credential Provider and WinSxS issue on Win7 x64 SP1 RRS feed

  • Question

  • Dear colleagues,

    I have recently faced a problem with a custom Credential Provider (developed by our company) and WinSxS on Win7 x64 SP1. Problem can be reproduced only on a single notebook against the hundreds of others workstations where everything is OK.

    Problem Details:

    Credential provider spawns a child process in its constructor. ::CreateProcess periodically fails with 0xC0000006 error. When I tried to run child process under WinDbg I received the following error message:

    “Could not create process “…process path…”, Win32 error 0n14001.

    The application  has failed to start because its  side-by–side configuration is incorrect. Please see the application event log  or use the command-line sxstrace.exe tool for more detail”.

    Credential provider and its subcomponents use Microsoft CRT 2008 SP1 Redistributables (proper version has been installed before Credential Provider execution). It’s practically impossible for us to switch from dynamic linkage with Microsoft CRT to static.

    I suspect WinSxS slow startup. For example, If I add ::Sleep(60000);  before ::CreateProcess the problem disappears.

    I would be grateful for any ideas.

    Tuesday, April 24, 2012 12:55 PM

All replies

  • "application event log" is your friend to figure out what exactly is going wrong.

    ----

    Nima Sharifimehr.
    sbucsc at yahoo dot com

    Wednesday, April 25, 2012 6:44 PM
  • Nima, thank you for advice.

    We used xperf from WPT to troubleshoot this issue (http://msdn.microsoft.com/en-us/performance/cc709422). 

    During OS startup xperf recorded series of PEND events for "C:\Windows\winsxs" and "C:\Windows\winsxs\x86_microsoft.vc90.crt_1fc8b3b9a1e18e3b_9.0.30729.6161_none_50934f2ebcb7eb57\msvcr90.dll" for child process of our credential provider.

    After deinstallation of Microsoft Forefront Client Security issue disappeared.

    We tried to reinstall Microsoft Forefront Client Security and updated it with the most recent updates. Problem couldn't be reproduced.

    Best Regards,
        Alexander Lobanov


    Alexander Lobanov

    Wednesday, May 2, 2012 10:54 AM