locked
Issues when trying to install Power Pivot for Excel 2010 RRS feed

  • Question

  • Hi all,

    I am trying to install Power Pivot for excel 2010 on various PCs around my business. Some have installed fine but others won't, and I cant seem to locate the issues why as I'm doing the same thing on each. Here are some pre requisite stats I have checked over:

    Operating System: Windows XP SP3

    Full version of Office 2010 (with Shared Tools Installed) 32 Bit

    .Net Frame work 4.0 is installed

    Visual Studio 2010 Tools for Office Runtime is Installed (Before Power Pivot)

    Power Pivot SQL Server 2012 is installed 32 bit

    I can confirm I am using the latest version of Power Pivot for Excel and that I have installed Visual Studio 2010 Tools for Office Runtime before Power Pivot.

    When I open Excel, Power Pivot does not load and I cannot see it in the Ribbon. I go to the Com add ins and I can see it is unticked. I tick it then press ok but nothing happens, when I go into Com add ins again Power Pivot has reverted to unticked. If I go to Disabled add ins, the list is empty so it not disabled. In the Load behaviour dialogue box on the com add ins page there is a message: 

    Not Loaded. A runtime error occurred during the loading of the com add-in.

    I have used the following page to ensure I have everything installed:

    https://msdn.microsoft.com/en-us/library/gg413462(v=sql.110).aspx

    I have also tried to google search the error messages over the last couple of weeks and I do not know what to do. What else can I try?

    Thanks in advance

    Thursday, September 24, 2015 11:52 AM

Answers

  • Chris,

    You might try this:

    This worked for me on my Windows 10 virtual machine. Grabbed it from a post I made on the Windows forum.

    This worked for me.
    1) Search for “regedit” via button beside Windows Key, Run regedit
    2) Navigate to: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework
    3) Right click on “.NETFramework”, select New > DWORD (32-Bit)
    4) Name it “useLegacyJit” (without the inverted commas)
    5) Right click the newly created item >
    Modify > Enter “1” in the Value data field, (Base should remain as HEX) Press OK

    6) Restart PC (Not sure why but without this step Add-In still won’t work)
    7) Launch Excel, then > Options >
    Add-ins > Manage Disabled Item > Select PowerPivot > Enable > Close

    8) Close Excel completely and launch it, and I see PowerPivot again!

    Thanks to Charles of PowerPivotPro.com for redirecting the solution
    http://forum.powerpivotpro.com/forums/topic/power-pivot-add-in-crashes-excel-2010-in-windows-10/

    Dennis

    • Proposed as answer by Charlie Liao Friday, September 25, 2015 7:27 AM
    • Marked as answer by Charlie Liao Thursday, October 8, 2015 9:21 AM
    • Unmarked as answer by SQL_Chris_ Wednesday, October 21, 2015 9:58 AM
    • Marked as answer by SQL_Chris_ Wednesday, October 21, 2015 9:58 AM
    Friday, September 25, 2015 12:56 AM

All replies

  • Chris,

    You might try this:

    This worked for me on my Windows 10 virtual machine. Grabbed it from a post I made on the Windows forum.

    This worked for me.
    1) Search for “regedit” via button beside Windows Key, Run regedit
    2) Navigate to: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework
    3) Right click on “.NETFramework”, select New > DWORD (32-Bit)
    4) Name it “useLegacyJit” (without the inverted commas)
    5) Right click the newly created item >
    Modify > Enter “1” in the Value data field, (Base should remain as HEX) Press OK

    6) Restart PC (Not sure why but without this step Add-In still won’t work)
    7) Launch Excel, then > Options >
    Add-ins > Manage Disabled Item > Select PowerPivot > Enable > Close

    8) Close Excel completely and launch it, and I see PowerPivot again!

    Thanks to Charles of PowerPivotPro.com for redirecting the solution
    http://forum.powerpivotpro.com/forums/topic/power-pivot-add-in-crashes-excel-2010-in-windows-10/

    Dennis

    • Proposed as answer by Charlie Liao Friday, September 25, 2015 7:27 AM
    • Marked as answer by Charlie Liao Thursday, October 8, 2015 9:21 AM
    • Unmarked as answer by SQL_Chris_ Wednesday, October 21, 2015 9:58 AM
    • Marked as answer by SQL_Chris_ Wednesday, October 21, 2015 9:58 AM
    Friday, September 25, 2015 12:56 AM
  • I have sent this request to my IT because they don't like me tinkering with REGEDIT. Once I get their confirmation I will try it.

    Many Thanks

    Thursday, October 1, 2015 11:08 AM
  • My IT dept have reset a profile (or somehting I'm not really involved with all that) and it has magically started to work. So I will not get chance to try this but thank you for posting it. 

    regards

    Wednesday, October 21, 2015 9:58 AM