locked
browsing OWC via client side problem RRS feed

  • Question

  • I have an issue when browsing Microsoft Business Scorecard Manager 2005 from another laptop, the PivotChart built with Microsoft Office Web Component version 12 can not connect to the Data Source, that is OLAP Cube built with Microsoft SQL Server 2005 Analysis Service.

    There is a warning sign in the OWC frame showing the error description:
    Failed to get data. If available, errors returned from the provider are listed below.
    - An error was encountered in the transport layer.
    - The peer prematurely closed the connection

    I already tried some attempts, but they did not help:<!--[if !supportLists]-->

    • The IE in client side already set : Enable Access Data Sources across domains in Security Settings
    • The connection string from OWC to Data Source is:
    • Provider=MSOLAP.3; Integrated Security=SSPI; Persist Security Info=True; Initial Catalog-KPI3_5;Data Source-mrgreen
    • I tried to connect OWC from client to data source manually with the same connection string, but it could not see the cube.
    • A role with appropriate permissions is created for the cube
    • From the client side, I logged in with the Administrator user name which is used the same to create the data warehouse, build cube and build the scorecard
    • On Server Side, in SQL Native Client Configuration, the TCP/IP is set Enabled
    • Microsoft SQL Server 2005 Analysis Services 9.0 OLE DB Provider is already installed for the client side
    • The address of the server side is added as Trusted side
    • In the server side, in Registry, below HKEY_CLASSES_ROOT \ MSOLAP \ CLSID has the same value with HKEY_CLASSES_ROOT \ MSOLAP.3 \ CLSID


    Because Microsoft Business Scorecard Manager 2005 I use now is the 180 day trial, I am wondering if it is the reason causes the problem. Unless if there is any solution for this issue?

    If is there anybody ever get through this problem, please give me a hint here. It would help me a lot.


    Thank you so much.


    Thursday, September 6, 2007 3:01 PM

Answers