none
open with explorer in sharepoint 2010 greyed out

    Question

  • Hell All,

    We have a single user were Open with explorer is grayed out. It used to work fine, but all of a sudden he cannot use this option and also the option for upload multiple documents is also grayed out.

    There is something is missing or stopped working when he logs to his machine. When he logs to a different machine he can see the option. I would rather not to create a new windows profile on his machine, but if everything fails, then I have no other option but to create him a new windows profile.

    Thanks,

    Yassar


    • Edited by Yassar Thursday, April 19, 2012 5:08 PM
    Thursday, April 19, 2012 5:08 PM

Answers

  • I would try and make sure IE 8 32-bit is used and upload multiple missing is generally caused by Silverlight missing.
    • Marked as answer by Yassar Wednesday, April 25, 2012 6:10 PM
    Thursday, April 19, 2012 5:09 PM

All replies

  • I would try and make sure IE 8 32-bit is used and upload multiple missing is generally caused by Silverlight missing.
    • Marked as answer by Yassar Wednesday, April 25, 2012 6:10 PM
    Thursday, April 19, 2012 5:09 PM
  • IE 9 is 32 bit
    Thursday, April 19, 2012 7:27 PM
  • Hi,

    Some good tips here in a similar thread, this one also suggests that the user is using the 64-bits version of IE 9 or he has an old version of Ms Office installed


    Regards Bjoern

    Thursday, April 19, 2012 8:35 PM
  • Did he recently upgrade or change anything on his computer like windows or office? As long has he has 32 bit office he should be good to go. Also make sure the sharepoint site appears in the local intranet zone for him in IE

    Please mark my response as an answer if appropriate.
    Learn.SharePoint.com

    Thursday, April 19, 2012 8:45 PM
  • Most probably the issue is with webDAV on client machine.

    try this:

    a. Goto Start --> Admin tools --> Services

    b. Check the status of the service called "WebClient".

    c. If this service is not running, start the service 

    d. Try connecting to SharePoint via Windows Explorer.

    e. Check the status the WebClient again.

    f. If the service was stopped/crashed refer http://support.microsoft.com/kb/2548470

    Once everything is working you can change the Startup type of the service to "automatic"

    Thursday, April 19, 2012 10:31 PM
  • I just checked user's IE and it was 64 bit.
    Wednesday, April 25, 2012 6:12 PM
  • 1. with IE developer tools select element by click button(http://msdn.microsoft.com/en-us/library/dd565627(v=vs.85).aspx#selecting), i can find the HTML for open with explorer button as follows:

    <a class="ms-cui-ctl-medium " id="Ribbon.Library.Actions.OpenWithExplorer-Medium" role="button" aria-describedby="Ribbon.Library.Actions.OpenWithExplorer_ToolTip" onclick="return false;" href="javascript:;" _events="[object Object]" unselectable="on" mscui:controltype="">

    2. Search for id Ribbon.Library.Actions.OpenWithExplorer in CMDUI.XML, i can find the setting as follows:

    Command="OpenWithExplorer"

    3. Search for OpenWithExplorer in IE source view(IE->View->Source), i can find the following data structure for Ribbon UI:

    {'Command':'OpenWithExplorer','ClickScript':'CoreInvoke\\u0028\\u0027NavigateHttpFolder\\u0027,\\u0027http:\\\\u002f\\\\u002fwin-citkf3c8r0o:7777\\\\u002fShared Documents\\u0027, \\u0027_blank\\u0027\\u0029;','HiddenScript':'!\\u0028SupportsNavigateHttpFolder\\u0028\\u0029\\u0029','LabelText':'Open with Windows Explorer','Description':'Drag and drop files into this library.'}

    It indicate that the HiddenScipt, which determine whether the button is disabled, is SupportsNavigateHttpFolder (thanks Jinchun http://social.msdn.microsoft.com/profile/jinchun%20chen/?ws=usercard-mini for this step);

    4. I can find SupportsNavigateHttpFolder function definition in INIT.JS,very simple, just return some browseris property value:

    function SupportsNavigateHttpFolder()
    {ULSxSy:;
     return (browseris.ie5up && browseris.win32);
    }

    5. I can find the browseris definition in INIT.JS also, it get the ie5up and win32 property value from useragent string. So, please run the javascript navigator.userAgent in IE developer tools console to get your userAgent value. I guess it might have been changed on your problematic system. you can modify it in IE developer tools->tools-change user agent string. for more about user agent string, please refer to http://msdn.microsoft.com/en-us/library/ms537503(v=vs.85).aspx

    function Browseris () {ULSxSy:;
     var agt=navigator.userAgent.toLowerCase();
     this.osver=1.0;
     if (agt)
     {
      var stOSVer=agt.substring(agt.indexOf("windows ")+11);
      this.osver=parseFloat(stOSVer);
     }
     this.major=parseInt(navigator.appVersion);
     this.nav=((agt.indexOf('mozilla')!=-1)&&((agt.indexOf('spoofer')==-1) && (agt.indexOf('compatible')==-1)));
     this.nav6=this.nav && (this.major==5);
     this.nav6up=this.nav && (this.major >=5);
     this.nav7up=false;
     if (this.nav6up)
     {
      var navIdx=agt.indexOf("netscape/");
      if (navIdx >=0 )
       this.nav7up=parseInt(agt.substring(navIdx+9)) >=7;
     }
     this.ie=(agt.indexOf("msie")!=-1);
     this.aol=this.ie && agt.indexOf(" aol ")!=-1;
     if (this.ie)
      {
      var stIEVer=agt.substring(agt.indexOf("msie ")+5);
      this.iever=parseInt(stIEVer);
      this.verIEFull=parseFloat(stIEVer);
      }
     else
      this.iever=0;
     this.ie4up=this.ie && (this.major >=4);
     this.ie5up=this.ie && (this.iever >=5);
     this.ie55up=this.ie && (this.verIEFull >=5.5);
     this.ie6up=this.ie && (this.iever >=6);
     this.ie7down=this.ie && (this.iever <=7);
     this.ie7up=this.ie && (this.iever >=7);
     this.ie8standard=this.ie && document.documentMode && (document.documentMode==8);
     this.winnt=((agt.indexOf("winnt")!=-1)||(agt.indexOf("windows nt")!=-1));
     this.win32=((this.major >=4) && (navigator.platform=="Win32")) ||
      (agt.indexOf("win32")!=-1) || (agt.indexOf("32bit")!=-1);
     this.win64bit=(agt.indexOf("win64")!=-1);
      this.win=this.winnt || this.win32 || this.win64bit;
     this.mac=(agt.indexOf("mac")!=-1);
     this.w3c=this.nav6up;
     this.safari=(agt.indexOf("webkit")!=-1);
     this.safari125up=false;
     this.safari3up=false;
     if (this.safari && this.major >=5)
     {
      var navIdx=agt.indexOf("webkit/");
      if (navIdx >=0)
       this.safari125up=parseInt(agt.substring(navIdx+7)) >=125;
      var verIdx=agt.indexOf("version/");
      if (verIdx >=0)
                 this.safari3up=parseInt(agt.substring(verIdx+8)) >=3;
     }
     this.firefox=this.nav && (agt.indexOf("firefox") !=-1);
     this.firefox3up=false;
     this.firefox36up=false;
     if (this.firefox && this.major >=5)
     {
         var ffVerIdx=agt.indexOf("firefox/");
         if (ffVerIdx >=0)
         {
      var firefoxVStr=agt.substring(ffVerIdx+8);
             this.firefox3up=parseInt(firefoxVStr) >=3;
      this.firefox36up=parseFloat(firefoxVStr) >=3.6;
         }
     }
    }
    var browseris=new Browseris();



    Thursday, April 26, 2012 2:24 AM
    Moderator
  • My client was experiencing a greyed out 'Upload Multiple Documents' button as well as a greyed out 'Open in Explorer' button. He was also using Chrome as his browser. When he re-opened in IE v12, problem resolved.

    lpmanitowoc

    Monday, May 18, 2015 8:07 PM