locked
Using VS 2005 Emulator Localhost Problem RRS feed

  • Question

  • User-1482891610 posted

    Hi

    I am developing a web application that will be also be viewed on a Mobile Device.  I have tried to use the Pocket PC Emulator that is included in VS2005 but it does ot see localhost.

    Do i need to setup a connection or something, any help would be much appreciated

     

    thanks in advance

     

    Tuesday, January 1, 2008 5:20 PM

Answers

  • User113421904 posted

    Hi BigMeat,

    If you test it from ASP.NET Web Development Server, it only supports accessing from the localhost. This is the limitation ASP.NET Web Development Server. Please publish it to IIS server to avoid this.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, January 3, 2008 3:05 AM
  • User-1482891610 posted

    Hi

     I have tried the following and still no joy:

    1)  Installed Active Sync
    2)  Tried the followings URL's
            http://mypcname/mywesbite
            http://mypcname:80/mywebsite

    3)  Turned off Windows Firewall

    When I install Active Sync do I need to create an actual connection between my emulated device and active sync, if so what port or type of connetion do i create?

    Alternatively are there any other emulators i can use to test my website

     Many thanks in advance

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, January 3, 2008 4:15 AM
  • User1634317999 posted

    In the Device Emulator Manager you have to connect to a device firstly, i. e. you have to start the emulator. Then you have to cradle the device, i. e. you have to establish a connection through ActiveSync. The port is the port your Server is using for the web application. If you are using the development server it will regularly not be port 80.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, January 3, 2008 4:57 AM

All replies

  • User-1223057304 posted

    if u want to connect  your pc ,first u have to connect with Active Sync and then ur emulator will automatically connected with ur pc.
     

    Tuesday, January 1, 2008 11:55 PM
  • User1634317999 posted

    Please do not use localhost with the device emulator. Use the machine name or computer name with the port.

    Wednesday, January 2, 2008 9:05 AM
  • User113421904 posted

    Hi BigMeat,

    If you test it from ASP.NET Web Development Server, it only supports accessing from the localhost. This is the limitation ASP.NET Web Development Server. Please publish it to IIS server to avoid this.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, January 3, 2008 3:05 AM
  • User-1482891610 posted

    Hi

     I have tried the following and still no joy:

    1)  Installed Active Sync
    2)  Tried the followings URL's
            http://mypcname/mywesbite
            http://mypcname:80/mywebsite

    3)  Turned off Windows Firewall

    When I install Active Sync do I need to create an actual connection between my emulated device and active sync, if so what port or type of connetion do i create?

    Alternatively are there any other emulators i can use to test my website

     Many thanks in advance

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, January 3, 2008 4:15 AM
  • User1634317999 posted

    In the Device Emulator Manager you have to connect to a device firstly, i. e. you have to start the emulator. Then you have to cradle the device, i. e. you have to establish a connection through ActiveSync. The port is the port your Server is using for the web application. If you are using the development server it will regularly not be port 80.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, January 3, 2008 4:57 AM
  • User-1882610795 posted

    Try connecting the emulator to your machine via ActiveSync.  Once it's connected open up Mobile IE and use your computer's IP address (with port number if necessary) instead of "localhost".  Should do the trick.

    Tuesday, June 17, 2008 12:06 PM