none
4010 856 Validation question RRS feed

  • Question

  • I'm just needed some clarification.  I have an 856. In that 856 I specify a value for the N103 (code qualifier).  Then I specify a value in N104.

    Now,  if I remove the value in N104, and leave a qualifier value in N103, Biztalk R2 does NOT fail the message.  

    My assumption is that the expected behavior should be a failure during  EDI validation since N103 exists, but N104 does not.


    Running Biztalk R2:


    Is this the designed behavior?

    TT
    Thursday, March 19, 2009 3:12 PM

Answers

  • TT,

    Segment syntax validation is not enabled by default in BizTalk.  You must manually activate this in each schema by setting the XSD annotation X12ConditionDesignator_Check in the schema to Yes.

    Hope this helps,


    Jim -- Pro Mapping in BizTalk 2009, Apress Books, March 23, 2009
    • Marked as answer by TT2804 Thursday, March 19, 2009 8:29 PM
    Thursday, March 19, 2009 6:01 PM

All replies

  • Hi,
         After changing the schema did u redeployed it? And you should restart the Hostinstance also for correct behavior.
    If this is also not working. Then first remove schema from the Biztalk. Then deploy it then restart the Biztalk services.



    Thanks
    Gyan
    Thursday, March 19, 2009 3:39 PM
  • TT,

    Segment syntax validation is not enabled by default in BizTalk.  You must manually activate this in each schema by setting the XSD annotation X12ConditionDesignator_Check in the schema to Yes.

    Hope this helps,


    Jim -- Pro Mapping in BizTalk 2009, Apress Books, March 23, 2009
    • Marked as answer by TT2804 Thursday, March 19, 2009 8:29 PM
    Thursday, March 19, 2009 6:01 PM
  • Yep,  that did the trick.  IReally should've scanned the docs a little better. 

    Thanks for the answer!!!!

    TT
    Thursday, March 19, 2009 8:28 PM