locked
MDS 2016 - Existing Attributes/Entities deployment issue - The model cannot be updated. 110003 RRS feed

  • Question

  • User-73514677 posted

    Hi.

    I am using the MDS version 13.1.0.3. The SQL server version is 13.0.4604.0 (SP-1).

    Deployment package is taken from the MDS UI and also from the Command prompt. When deploying existing attributes / entities, I am getting error as  - The model cannot be updated. 110003: The name already exists. Type a different name.

    Deployment scenarios that work as usual :

    1. New entity
    2. New attribute to existing entity

    Issues found so far:

    1. Whenever there is a change in the length or data type of an existing attribute, MUID is changed. - Updating the MUID to the older one eliminates any changes done to the attribute.
    2. Stored procedure has a filter to check the Name of the attribute and therefore checks the MUIDs of the attributes, thereby eliminating any changes done to the attribute due to differing MUIDs. This check was not previously in MDS 2012 – updating the MDS system generated stored procedure to comment this filter is not the preferable method to address the issue.
    3. I have also tried to change the transaction type of all the entities.
    4. I have tried to deploy only the entity with the subscription views and eliminating the Business Rule.

    None of the above scenarios have worked.

    Do we have to follow any other methods to deploy the changes made? Is there any updates missing from the above MDS version? Any workaround to resolve the same?

    Thanks

    Monday, January 20, 2020 11:36 AM

All replies