locked
How to suppress Step Into messages RRS feed

  • Question

  • How do supress the messages that apear in the Immediate Window when I press F8:

    Step into: Stepping over non-user code XXXXXXXXX

    VS2010, VB.Net

    Wednesday, March 17, 2010 5:34 PM

Answers

  • Hi Bob,

    Thank you for your post.

    Some clarification with you:
    Which edition of Visual Studio 2010 are you running now?

    As far as I know, the debug feature "Step into: Stepping over non-user code" should be displayed in Output Windows.
    Based on your description, it seems that this message (Output Windows) is shown in the Immediate Window.

    Could you please help me to check Tools menu >> Options >> Debugging >> General >> Redirect all Output Window text to the Immediate Window? Please make sure that this feature is unchecked.

    If it doesn't work, please run devenv /Resetsettings in Command Prompt to eliminate the cause of corrupted settings.
     
    Hope this helps! If you have any concern, please feel free to let me know.

    Best regards,
    Yichun Chen


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by Bob Heitzman Friday, March 19, 2010 9:52 PM
    • Edited by YiChun Chen Monday, March 22, 2010 2:53 AM typo
    Friday, March 19, 2010 10:09 AM

All replies

  • 1. In the Output window, select "Debug" in the Show output from: dropdown.
    2. Right-click inside the Output window.
    3. Uncheck Step filtering messages.


    - Kemp Brown [MSFT]
    • Proposed as answer by Kemp Brown Thursday, March 18, 2010 1:22 AM
    Thursday, March 18, 2010 1:22 AM
  • No joy... Vs2010 Beta, Vb.Net is the environment

    Steps above didn't help.

    Tools, Options, Debuging, Output Window has the same option and it was set to No to no effect.

    I am getting the Step messages in the Immediate Window when I press F8.

    When VS2010 was installed I requested the VB profile if that makes a difference.

    In previous version (2005 for me) we had a choice of function key profiles and I choose the one that used F8 for Step. I don't know if those old settings impacted VS2010 or not but, I do have the 'old' function key profile.

    I get the same messages if I use the menus to Step.

    Here is a typical set of code and the Immediate Window text:

            For Each row In rowOthers
                Debug.Print(row(0))
                If CInt(row(0).ToString) <= CInt(txtKey1.Text) Then Exit For
                sNewKey = row(0)
            Next
    
    11599
    Step into: Stepping over non-user code 'System.Data.DataRow.this[int].get'
    Step into: Stepping over non-user code 'TE01.frmInspection.txtKey1.get'
    Step into: Stepping over non-user code 'System.Data.DataRow.this[int].get'
    Step into: Stepping over non-user code 'System.Data.DataRow.this[int].get'
    11595
    Step into: Stepping over non-user code 'System.Data.DataRow.this[int].get'
    Step into: Stepping over non-user code 'System.Data.DataRow.this[int].get'
    Step into: Stepping over non-user code 'System.Data.DataRow.this[int].get'
    10255
    
    Thursday, March 18, 2010 3:16 PM
  • Hi Bob,

    Thank you for your post.

    Some clarification with you:
    Which edition of Visual Studio 2010 are you running now?

    As far as I know, the debug feature "Step into: Stepping over non-user code" should be displayed in Output Windows.
    Based on your description, it seems that this message (Output Windows) is shown in the Immediate Window.

    Could you please help me to check Tools menu >> Options >> Debugging >> General >> Redirect all Output Window text to the Immediate Window? Please make sure that this feature is unchecked.

    If it doesn't work, please run devenv /Resetsettings in Command Prompt to eliminate the cause of corrupted settings.
     
    Hope this helps! If you have any concern, please feel free to let me know.

    Best regards,
    Yichun Chen


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by Bob Heitzman Friday, March 19, 2010 9:52 PM
    • Edited by YiChun Chen Monday, March 22, 2010 2:53 AM typo
    Friday, March 19, 2010 10:09 AM
  • In my case the dialog path is:

    Tools, Options, Debuging, Output Window, General Output Settings, All debug output - Off

    Setting this option to Off did suppress the messages. The dialog warns that all trace output is also off.

    Thanks!

    Friday, March 19, 2010 9:54 PM