none
Windows 10 -- VS2017, default DX12 UAP sample fails to start when built in Debug, but works in Release

    Question

  • I just reinstalled Visual Studio 2017 Professional, and updated to the latest update (as of April 23, 2017).  Upon creating a new project, using the DX12 sample for UAP, I get the following error upon building and attempting to run the sample, under the Debug configuration:

    ------------------------------------

    "Unable to activate Windows Store app

    <app id, I won't copy it here>

    The <app name> process started, but the activation request failed with error 'The app didn't start'"

    ------------------------------------

    Specific info:

    • The sample works in Release without issue -- it only exhibits this issue in Debug.
    • Dev machine is using Windows 10 x64 Professional, with Creator's Update (build 15063)
    • Dev machine is DX12 capable (nVidia GTX 870M with latest drivers)
    • My MSA is logged in, for Windows, Windows Store, and VS 2017.
    • App is both targeting, and specifies a min version of, the Creator's Update (build 15063)
    • Architecture is set to x64, for all considerations.
    • There is no "app.config" file present (reported as present in previous cases of issues similar to this)
    • The sample is entirely unchanged/untouched from the default.  It is broken out-of-box.
    • I have wiped the project and recreated it: the result is the same.
    • I have reinstalled VS 2017 (*grumble*): the result is the same.
    • This appears to be a new issue: I have successfully created and run the DX12 sample previously, in Debug, on this hardware, under the Anniversary update (Windows 10, build 14393).






    • Edited by M.McG Sunday, April 23, 2017 10:52 PM
    Sunday, April 23, 2017 10:45 PM

All replies

  • Hi M.McG,

    Welcome to the MSDN forum.

    >> This appears to be a new issue: I have successfully created and run the DX12 sample previously, in Debug, on this hardware, under the Anniversary update (Windows 10, build 14393).

    It looks like this issue relates to the Creator's Update, please try to remove this update through Settings-Update and security-Recovery. Under “Go back to the previous version of Windows 10,” click the Get started button to roll back. If this issue is disappeared on the previous version, please use the Feedback Hub app to share this issue with the Windows 10 Product Team.

    Meanwhile, please have a look at this similar issue: Visual studio 2017 not starting empty project just created and some other community members met the debug issues after the Creator’s Update, Soludayo shared the following information:

    I expect the Visual Studio Team to investigate this issue and give a workable solution not just keep suggesting untested steps for us to resolve the issue.

    To Fellow Developers

    Your best option for now include:

    1. Run your project in release mode. This will work fine.

    2. If you are doing a C# UWP app, you can go to Properties->Build and Check Compile with .net Native tool chain. (You have to do this for every project but note that it doesn't work for some projects and I still don't know why.)

    3. Roll back to the point before the problem started

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, April 25, 2017 6:11 AM
    Moderator
  • Hi M.McG,

    Sorry to trouble you and I just want to confirm that your issue is solved or not?

    If not, please have a look at this: VS 2017 pro will not launch a UWP app in debug mode and have a try with the following:

    1) Open an elevated PowerShell console window.

    2) Run these commands (adjust the paths to the appx packages as per your machine setup):

    add-appxpackage "C:\Program Files (x86)\Microsoft SDKs\Windows Kits\10\ExtensionSDKs\Microsoft.VCLibs\14.0\Appx\Debug\x64\Microsoft.VCLibs.x64.Debug.14.00.appx"

    add-appxpackage "C:\Program Files (x86)\Microsoft SDKs\Windows Kits\10\ExtensionSDKs\Microsoft.VCLibs\14.0\Appx\Debug\x86\Microsoft.VCLibs.x86.Debug.14.00.appx"

    If you already solved your issue, you can also share the solution in here and mark it as answer, that will help other community members to search this solution, thank you for your cooperation.

    Best regards,

    Sara


    MSDN Community Support<br/> Please remember to click &quot;Mark as Answer&quot; the responses that resolved your issue, and to click &quot;Unmark as Answer&quot; if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact <a href="mailto:MSDNFSF@microsoft.com">MSDNFSF@microsoft.com</a>.

    Wednesday, May 10, 2017 6:28 AM
    Moderator