locked
authentication error when trying to use rs.exe with the ssrs_migration.rss script RRS feed

  • Question

  • Hi 

    I am trying to migrate some reports from a 2008 instance to a 2012 instance using rs.exe with  ssrs_migration.rss script.

    i.e. like this

    rs.exe -i ssrs_migration.rss -e Mgmt2010 -s http://sourceserver.domain/ReportServer -u domain\user -p password -v ts="https://destserver.domain/reportserver" -v tu="domain\user" -v tp="password" -v f=”GB_TEST” -v tf=”GB_TEST” -v security=”True”

    The first step, that checks things, works ok. Then you are asked if you want to continue by pressing ENTER.

    If I continue I get an error 

    Migrating Role : Browser ...  FAILURE:

    The request failed with HTTP status 401: Unauthorised.

    and this is repeated for everything that its trying to migrate...

    I would note that the destination server (ssrs 2012) has a reportserver url using  https, whilst the source is http (ssrs 2008).

    The account being used to do the migration is in the local admin group on both servers - and has been added to the report manager with the system administrator and system user roles.

    I have tried running the rs.exe on both the source and desination server -same result.

    I do get an error when trying to hit https://destserver.domain/reportserver from a browser on the destination server, but not on the source server (where it works). On the destination server, the error is 

    • The permissions granted to user 'domain\username' are insufficient for performing this operation. (rsAccessDenied) 

    Can anyone see why we are getting the 401 error.

    Monday, July 10, 2017 5:33 PM

Answers

  • aargh - the password was wrong on the destionation server ....

    all ok now.

    • Marked as answer by goofygdog2 Monday, July 10, 2017 5:43 PM
    Monday, July 10, 2017 5:43 PM