locked
How do I get more Verbose Error info from MDSModelDeploy.exe RRS feed

  • Question

  • c:\Program Files\Microsoft SQL Server\120\Master Data Services\Configuration\MDSModelDeploy.exe"  deployupdate -package \\garble\foo\CC_ST1_150921__v1_0_0_5391.pkg  -service MDS1
    Deploying package \\garble\foo\CC_ST1_150921__v1_0_0_5391.pkg
    , updating model CC

    MDSModelDeploy operation failed. Elapsed time: 00:04:29.7015493
    Error:
    The model cannot be updated.
    An error occurred while processing message request type 'BusinessRulesCloneReque
    st'. See exception details for more information.
    Package deployment failed with 5 errors

    The attribute reference is not valid. The attribute was not found.
    The attribute reference is not valid. The attribute was not found.
    The attribute reference is not valid. The attribute was not found.
    The attribute reference is not valid. The attribute was not found.
    The attribute reference is not valid. The attribute was not found.

    I need more information about which attribute is causing this or at least which entity, is it possible?

    Enabling Verbose tracing in MDS Web Application doesn't seem to log any of these errors.

    SQL Server 2014 SP1 CU2.

    Model package is probably SQL Server 2014 RTM

    Anyone?

    Regards, Fredrik

    Monday, November 16, 2015 11:48 AM

Answers

  • I actually found the normal system.diagnostics settings in the MDSModelDeploy.exe.config so I'll try that!

    And a great blog article about it from Jason H

    http://blogs.msdn.com/b/jason_howell/archive/2012/09/13/enabling-logging-to-troubleshoot-mdsmodeldeploy-exe.aspx

    /F

    Monday, November 16, 2015 12:38 PM

All replies

  • I actually found the normal system.diagnostics settings in the MDSModelDeploy.exe.config so I'll try that!

    And a great blog article about it from Jason H

    http://blogs.msdn.com/b/jason_howell/archive/2012/09/13/enabling-logging-to-troubleshoot-mdsmodeldeploy-exe.aspx

    /F

    Monday, November 16, 2015 12:38 PM
  • Hi Fredrik,

    Thank you for your sharing which will help others who have similar issue.

    Regards,


    Charlie Liao
    TechNet Community Support

    Tuesday, November 17, 2015 2:34 AM