none
MSMQ Assembly error on receive. RRS feed

  • Question

  • HI All,

    I have written 2 components (separate assemblies). The first one writes to MSMQ and the second reads from the queue.

    When I attempt to read from the Queue I receive the following error :

    Unable to find assembly 'assembly name of the component that wrote to the queue'

    Monday, July 20, 2015 11:48 AM

Answers

  • I Found the answer a while ago sorry for not updating the question.

    Basically, the Data object that I was sending, I needed to place in it's own dll, then make a reference to this dll from both the sender and receiver projects. Because both then referenced the same 'data library' assembly the data could be retrieved.

    • Marked as answer by BillCrawley Tuesday, July 28, 2015 10:39 AM
    Tuesday, July 28, 2015 10:39 AM

All replies

  • Hi BillCrawley,
    According to this case , I Suggest you to check out sending and

    receiving message formats is matching or not.

    Then check out transmission path is correct or not.

    I hope that will be helpful to you.
    Best Regards,
    Tracy Dj


    Best Regards, Tracy Dj

    Tuesday, July 21, 2015 2:44 AM
    Moderator
  • I Found the answer a while ago sorry for not updating the question.

    Basically, the Data object that I was sending, I needed to place in it's own dll, then make a reference to this dll from both the sender and receiver projects. Because both then referenced the same 'data library' assembly the data could be retrieved.

    • Marked as answer by BillCrawley Tuesday, July 28, 2015 10:39 AM
    Tuesday, July 28, 2015 10:39 AM