none
Problem Installing Visual Studio Community 2015 RRS feed

  • Question

  • I can't install Visual Studio Community 2015. When the installation finishes a message saying:

    "Setup Completed. However not all features installed correctly". Below that it says:

    Microsoft Visual Studio Enterprise 2015

     Package failed

    Trying to launch the program after fails and a message pops up saying I need to reinstall or repair the program.  

    Repairing results in the same result and I have tried reinstalling with three different isos so far with the same result.

    I have recently uninstalled Visual Studio Professional 2013 before trying to install this version.

    Wednesday, September 9, 2015 11:27 PM

All replies

  • Hi, Didinchukar

    Thanks for reporting the issue, I am sorry to hear about the Visual Studio Community 2015 install error issues you are having .I can imagine the inconvenience you have experienced. We will try to help you with this.

    You mentioned that you wanted to install VS community, the error message is: VS enterprise 2015 package failed. It seems that you have downloaded both community and enterprise version.

    Could you please tell us in which website did you download the iso image files? If you didn’t download it from official ways, you can go to the Microsoft’s official site to download visual studio 2015 community, here is the download link: https://www.visualstudio.com/en-us/downloads/download-visual-studio-vs.aspx

    After downloading iso files, please use the File Checksum Integrity Verifier utility to determine if the source file is corrupt during installation problems. The checksum is used to compare the downloaded file to the original. If the checksum is the same then the file has been downloaded fully. Checksums are used to validate file integrity.

    The FCIV utility can be downloaded from Microsoft's support database here: http://support.microsoft.com/kb/841290

    please compare the checksum that official site provides with your own to make sure your disc image file is ok, a checksum is a unique number that is assigned to a file upon creation.

    Visual Studio 2015 ISO Files SHA-1 Values are in the link here:https://www.visualstudio.com/en-us/downloads/visual-studio-2015-iso-sha1-vs.aspx

    Hope it will be helpful to you. Please feel free to ask us if you encounter any other problems after trying these steps.

    Best Regards

    Wen Xu

     

    Thursday, September 10, 2015 9:13 AM
    Moderator
  • Thank you for the reply.  

    I got the iso from dreamspark.com, running fciv gave me a SHA-1 of baad3cebab7a5834d8f78f7d02e4880c010f3ba9 which seems to match the expected result. 

    I downloaded Microsoft Visual Studio Community 2015 from the dreamspark download page and ran the exe from the iso and that was the result I got. I can't share images here yet but the final dialogue said Community 2015 at the top but in the bellow section it said 

    Microsoft Visual Studio Enterprise 2015

     Package failed

    Ive tried to install Enterprise after but I got the same result.

    EDIT: I'm on a laptop running windows 8.1. I have a VM on here that runs windows 8 pro and I managed to successfully install VS Community using the same iso.


    • Edited by Didinchukar Thursday, September 10, 2015 3:15 PM
    Thursday, September 10, 2015 3:13 PM
  • @Didinchukar,

    If the ISO checksum is alright, we need to check your OS for details.

    What about share us your full logs:Please use  http://aka.ms/vscollect  to gather the installation logs. After using it, you will find vslogs.cab from %temp% folder. Please upload the file to https://skydrive.live.com/  and share the link here.

    By the way, have you installed all Windows 8.1 updates yet? You may try sfc /scannow to check for your system files.

    Best regards,

    Barry


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, September 11, 2015 2:56 AM
    Moderator