none
can't create .net project after installed SP1 --.net2008 RRS feed

  • Question

  • Hi all:
    I saw lots of discussion for this issue (VS2008 with SP1 -- can't create project). I tried all the solution and nothing works on my PC. If I removed SP1 , it works.Can I get help to make it work after I install SP1?

    What I installed?
    1. Installed Visual Studio 2008
    2. Install Visual Studio 2008 SP1 from this URL
     
    Then I got error when I created new project
     
       
    What I had been done in order to fix this problem?
     
    1. uninstall all and reinstalled -- failed
     
    2. run devenv /resetskippkgs  --- still save error
    3. run
    devenv setup
    Devenv resetskippkgs
     --still same error
     
    4. update registry key value from 1 to 0 ( Visual Studio -- > 9 --> package)  -- didn't  work
     
    • Changed type YiChun Chen Wednesday, July 15, 2009 3:54 AM Do not follow up
    • Changed type NeiMeng Tuesday, July 21, 2009 3:40 AM didn't get email notification for reply before
    Wednesday, July 8, 2009 4:43 AM

All replies

  • Hi NeiMeng,

    Which edition of Visual Studio 2008 are you running now? What's your OS? What's the exact error message? What kind of project did you create when you got the error message? Will this situation happen on other project?

    Could you please help me to check the project template files on disk:

    Project templates
    %programfiles%\Microsoft Visual Studio 9.0\Common7\IDE\ProjectTemplates\CSharp
    %programfiles%\Microsoft Visual Studio 9.0\Common7\IDE\ProjectTemplates\VisualBasic
    %programfiles%\Microsoft Visual Studio 9.0\Common7\IDE\ProjectTemplates\Web\CSharp
    %programfiles%\Microsoft Visual Studio 9.0\Common7\IDE\ProjectTemplates\Web\VisualBasic
    .......

    If these files can be found, please try running devenv.exe /InstallVSTemplates.
    Visual Studio uses a cache on disk of all the installed project/item templates, to rebuild the cache, please run devenv.exe /InstallVSTemplates (in Start > Run or "Visual Studio 2005/2008 Command Prompt")

    You also can try running devenv.exe /ResetSettings to isolate the settings problem.

    If it doesn't work, I found a similar issue on the Internet, see: https://connect.microsoft.com/VisualStudio/feedback/ViewFeedback.aspx?FeedbackID=329986

    Could you please try Process Monitor tool http://www.microsoft.com/technet/sysinternals/utilities/processmonitor.mspx which can capture the access log.
    Filter on the process name devenv.exe in the log so that you see only the related list.
    This should give you more info on what are the registry keys/ files being accessed when error happens.
    Please check which blocks project creation (like if there is any Regopenkey "Access Denied").

    Let me know if it works.

    Thanks
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Edited by YiChun Chen Wednesday, July 15, 2009 6:52 AM typo
    Thursday, July 9, 2009 8:20 AM
  • Hi NeiMeng,

    We are changing the issue type to “Comment” because you have not followed up with the necessary information. If you have more time to look at the issue and provide more information, please feel free to change the issue type back to “Question” by editing your initial post and changing the radio button at the top of the post editor window. If the issue is resolved, we will appreciate it if you can share the solution so that the answer can be found and used by other community members having similar questions.

    Thank you!
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Wednesday, July 15, 2009 3:54 AM
  • Sorry, I didn't get email notofication so I thought no one rplied

    I installed enterprise version on my PC. OS is window xp with SP2 . I tried to create vb.net web project. Since I installed SP1, I can't create any new projects so far.

    yes. all templates files which you need me to check exist at  my PC.

    I ran the commend line and the error is still same.

    the error message:Package load failure

    "Package visual studion Debugger" has failed to load properly { Guid= {C9DD4A57-47FB-11D2......}
    Please contact package vendor for assistance.
    Application restart is recommended.Due to possible environment corruption.WOuld you like to disable loading this package in the future?
    You may use 'devenv /resetskippkgs' to re-enable package loading.

    I select "No" based on web answer and then no project was created

    SInce so many people get this erro. MS will re release hotfix fir this issue?

    THanks
    Helena
       

    Tuesday, July 21, 2009 4:07 AM
  • sorry. the version which I installed is: visual studio standard Edition - ENU
    Tuesday, July 21, 2009 4:18 AM