locked
How to update Nuget on VS 2012? RRS feed

  • Question

  • Hello all. I'm trying to use the SIMD functionality of .NET 4.6.1 in Visual Studio 2012 (express desktop) and I'm having some trouble. I'm able to target .NET 4.6.1 in the Project Properties page, but when I right-click the project in the Solution Explorer, select "Manage Nuget packages...", search and select the "System.Numerics.vectors" package and attempt to install I get an error claiming:

    "The System.Numerics.Vectors 4.1.0 package requires NuGet client version 3.0 or above, but the current NuGet version is 2.8.60318.677".

    When I click the "Upgrade NuGet" button nothing seems to happen. Can someone please provide some guidance? Thank you in advance.

    -L

    Monday, January 11, 2016 11:01 PM

Answers

  • Hi LKeene,

    Please open the Extensions and Updates in Tools menu and then select the Update tab -> Visual Studio Gallery -> NuGet Package Manager, it will show an Update menu. Please update it with this update button.

    Best Regards,
    Weiwei

    • Proposed as answer by Weiwei Cai Tuesday, January 19, 2016 10:28 AM
    • Marked as answer by Weiwei Cai Wednesday, January 20, 2016 3:12 AM
    Wednesday, January 13, 2016 6:09 AM

All replies

  • Hi LKeene,

    Please open the Extensions and Updates in Tools menu and then select the Update tab -> Visual Studio Gallery -> NuGet Package Manager, it will show an Update menu. Please update it with this update button.

    Best Regards,
    Weiwei

    • Proposed as answer by Weiwei Cai Tuesday, January 19, 2016 10:28 AM
    • Marked as answer by Weiwei Cai Wednesday, January 20, 2016 3:12 AM
    Wednesday, January 13, 2016 6:09 AM
  • Hi,

    it is impossible to update the Nuget Package Manager like that in VS 2012. Any ideas how to solve it? The highest it goes is version 2.8.60318.667

    • Edited by SvanevitS Wednesday, July 25, 2018 11:51 AM
    Wednesday, July 25, 2018 11:47 AM
  • That only works if you have an update. The OP stated there are no pending updates for their version and also mentioned they have a much later version than what is evident in your image. In fact the OP has the version you're about to update to.
    Friday, March 13, 2020 12:56 AM