locked
IIS Express Script Documents - Application Debugging Disabled RRS feed

  • Question

  • User-380321707 posted

    I'm struggling with the same problem described here but that thread is closed.  I've gone through Dixon's Blog and also updated the proper config file, but I'm still getting "Application Debugging is Disabled".  This is happening in VS2017 Enterprise and VS2019 Enterprise.

    Are there any other configurations I need to apply?

    Friday, June 21, 2019 7:40 AM

All replies

  • User-848649084 posted

    Hi,

    Which OS you are using?

    You don't need to create applicationhost.config at your project folder.

    follow the below steps to enable debugging in iis express:

    1.open iisexpress applicationhost.config file from this location:

    C:\Program Files (x86)\IIS Express\config\templates\PersonalWebServer

    2.edit below section 

    <asp scriptErrorSentToBrowser="true">
        <cache diskTemplateCacheDirectory="%TEMP%\iisexpress\ASP Compiled Templates" />
        <limits />
    </asp>

    To

    <asp scriptErrorSentToBrowser="true" enableParentPaths="true" bufferingOn="true" errorsToNTLog="true" appAllowDebugging="true" appAllowClientDebug="true">
        <cache diskTemplateCacheDirectory="%TEMP%\iisexpress\ASP Compiled Templates" />
        <session allowSessionState="true" />
        <limits />
    </asp>

    3.Open visual studio.

    4. Select Open website and select your classic asp folder.

    5. Start the website without debugging (Ctrl+F5)

    6. In Visual Studio, open the “Attach to Process” dialog (Ctrl+Alt+P).the “Attach to” has the default option “Automatic: Native code”  change it to script.

    7.attach to IIS Express.

    Run the project.

    Regards,

    Jalpa

    Monday, June 24, 2019 5:56 AM
  • User-380321707 posted

    Thanks for the settings but it's still not working.  I'm getting the same result as my previous post.  BTW, I'm on Win10.

    Monday, June 24, 2019 2:11 PM
  • User-848649084 posted

    Hi,

    Go to this location C:\Program Files (x86)\IIS Express\config\templates\PersonalWebServer and open applicationhost.config and share that config file. and your site folder using one drive if possible. if you host site in iis than share iis asp feature setting snapshot after selecting site.

    Tuesday, June 25, 2019 7:18 AM
  • User-380321707 posted

    Here's a link to the file.  I put the settings described above in that also, but to no avail.

    https://1drv.ms/u/s!ApzPbwb_9H4Gg-wO_yXq3-A7_fNGHA

    Tuesday, June 25, 2019 2:21 PM
  • User-848649084 posted

    Hi,

    You did not set below code in your applicationhost.config file:

    <asp scriptErrorSentToBrowser="true" enableParentPaths="true" bufferingOn="true" errorsToNTLog="true" appAllowDebugging="true" appAllowClientDebug="true">
        <cache diskTemplateCacheDirectory="%TEMP%\iisexpress\ASP Compiled Templates" />
        <session allowSessionState="true" />
        <limits />
    </asp>

    Wednesday, June 26, 2019 7:27 AM
  • User-380321707 posted

    I did set it, tested it, it didn't work, so I put the file back to it's original condition.  I've posted the updated file.

    https://1drv.ms/u/s!ApzPbwb_9H4Gg-waNimgXEgms7LafA

    Wednesday, June 26, 2019 7:33 AM
  • User-848649084 posted

    are you trying to use the site with iis?

    Wednesday, June 26, 2019 7:36 AM
  • User-380321707 posted

    IIS Express v10 and VS2017 Enterprise or VS2019 Enterprise

    Wednesday, June 26, 2019 7:38 AM
  • User-848649084 posted

    did you remove applicationhost.config file from your project folder?

    Wednesday, June 26, 2019 7:39 AM
  • User-380321707 posted

    I deleted the .vs folder and let it get recreated by VS2017.  The applicationhost.config file was not recreated so now it's gone.

    Wednesday, June 26, 2019 7:41 AM
  • User-848649084 posted

    you can reinstall visual studio.

    Wednesday, June 26, 2019 7:45 AM
  • User-380321707 posted

    I just installed VS2019 a few days ago and it's not working either.   Nor does it create the config file in the .vs folder

    Wednesday, June 26, 2019 7:50 AM
  • User-848649084 posted

    try to access this folder location  C:\Program Files (x86)\IIS Express\config\templates\PersonalWebServer check there is any applicationhost.config file or not.

    Wednesday, June 26, 2019 7:52 AM
  • User-380321707 posted

    That's the one i was told to edit on 06-25-2019 07:18 AM, and that's the one that I've posted.

    Wednesday, June 26, 2019 7:58 AM
  • User-848649084 posted

    do the changes which i suggest in that post restart visual studio. 

    Wednesday, June 26, 2019 8:00 AM
  • User-380321707 posted

    I've done that many times with both VS2017 and VS2019.  I've also rebooted several times since this thread started a couple days ago.

    Wednesday, June 26, 2019 8:02 AM
  • User-848649084 posted

    hi,

    Which bit of iis express you are using? 

    Thursday, June 27, 2019 9:00 AM