none
ReportViewer not passing parameters RRS feed

  • Question

  • Hello,

    Im tring to setup the ReportViewer control onto a page but it seems to be having a weird issue on my machine. For some reason the report does not pass the parameters that you give it, but only when it is compiled on my machine. We have tried this on another computer and everything works fine. We have verified the versions of all of the files that we have installed for .NET and their corrosponding service packs and we have the exact same versions, down to the minor and build version. I have attempted reinstalling .NET and Visual Studio, along with trying to use his assembly files for the ReportViewer. I made sure that the assemblies that i am accessing are not the ones in the Global Assembly Cache and that every assembly was the exact same as his.

    I have also tested to see if it was a problem with my internet browser. When he compiles the simple app and publishes it, i can run it on my machine with no problems. When i compile and publish, it doesnt work on his computer. This leads me to believe that the problem is not IE7 or IE8.

    The code that we are compiling is exactly identical and is using the same assemblies. The only thing that i could think of that might be causing this would be ether my .NET installation or my Visual Studio Pro instalation, which i have tried reinstalling both.

    Any help would be greatly appreciated and would save a lot of future head aches.


    Thanks,

    Chris Haws
    Thursday, March 12, 2009 11:51 PM