locked
SOAP adapter connection timeout RRS feed

  • Question

  • Hi Friends,


    I have an expose a BizTalk Orchestration as a Webservice using the autogenerated publishing wizard which internally calls an service using the Http adapter.

    I am getting a connection time out issue.Following is the error.

    Error details: The original request has timed out. The response arrived after the timeout interval and it cannot be delivered to the client.




    In order to resolve this i had change the connection timeout property on the IIS to big number but its giving the same error.

    Can someone help me out.
    cas1980
    Thursday, December 11, 2008 6:00 PM

Answers

All replies

  • Have seen the same errors around SOAP and WSE Adapters.
    Hope these help. 
    http://support.microsoft.com/kb/952567/en-us
    http://support.microsoft.com/default.aspx/kb/924638
    • Proposed as answer by DPS Bali Monday, March 1, 2010 1:48 PM
    • Marked as answer by Ben Cline1Moderator Wednesday, January 5, 2011 8:33 PM
    Thursday, December 11, 2008 6:52 PM
  •  

    It depends on a couple of things:

    1. The keep-alive and timeout setting of the client calling your web service. You can change the timeout of what's calling the web service to a bigger value if it's timing out before BizTalk sends a response.

    2. The speed at which your orchestration is returning a response. In your orchestration, do you need to wait until the end of the orchestration before sending a response? Can you make changes to it to send a faster reply on the request-response?

    You also need to check if there aren't any pipeline exceptions happening on the SOAP receive. This will cause BizTalk never to send a response to the client and it will eventually timeout and you get that exception in the event log.


    Thiago Almeida - Datacom NZ
    Thursday, December 11, 2008 10:22 PM
    Answerer
  • Hi
    I got it working.What i did is the following.I went to the BizTalk Auto generated webservice on C:\inet\wwwroot & added the following in the web.config file:

    <httpRuntime executionTimeout="1200"></httpRuntime>
    cas1980
    Friday, December 12, 2008 4:30 PM
  • I just handled this issue for a client today and the httpRuntime executionTimeout value worked for us. The following link is a great troubleshooting guide on errors from use of the SOAP adapter: http://msdn.microsoft.com/en-us/library/dd297484(BTS.10).aspx.

    Thanks,


    If this answers your question, please use the "Answer" button to say so | Ben Cline
    Wednesday, January 5, 2011 8:34 PM
    Moderator