Previously-purchased durable IAPs not being recognized RRS feed

  • Question

  • We have a very old IAP that has worked for a long time. We have not made any changes to it. The code snippet we use to check for valid license information has not changed:

    return CurrentApp.LicenseInformation.ProductLicenses[productKey].IsActive;

    We've recently had a lot of users contact us and report that their previous purchases are not active.  We were able to quickly/easily reproduce this by setting up a new Microsoft account, purchasing the IAP, and then watching as our app fails to recognize the valid license.

    Is anyone else experiencing this issue?  We appear to be having the problem only on Win 10 devices (both desktop and mobile).  Windows 8.1 devices do not appear to be affected.

    We attempted to open a support ticket with Microsoft and received the following (see image). 

    We tried selecting different support options - "Support for Writing Apps" with a category of "Microsoft APIs" and we were able to reach the final stage of submitting an incident.  When we submitted, we received another error message.  We will update this post when/if we can confirm if we successfully opened an incident with Microsoft.

    • Edited by acme_hap Friday, December 18, 2015 9:57 PM
    Friday, December 18, 2015 9:06 PM

All replies

  • Hello,

    I am facing a worrying issue, all of a sudden my app stopped recognising that my app has in app purchases.

    I normally check to see if a user has purchased an IAP using the following:

    var currentApp = Windows.ApplicationModel.Store.CurrentApp; var licenseInformation = currentApp.licenseInformation.productLicenses; function isPremium() { return licenseInformation.lookup("cloudSync").isActive; }; If (isPremium()){
    // Do Something

    However all of a sudden licenseInfomation is completely blank! It is not showing the IAP options at all. I have some other code in the app to check for the IAP prices in local currency and this is sill working.

            currentApp.loadListingInformationAsync().done(function (listingInformation) {
                //Listing Information

    I am very concerned, is this a known issue or are there other reports of this about? I found this out because I migrated my Azure Mobile Service to an Azure App Service, I wanted to check that everything was still working okay and to my horror it wasn't. I assumed this was because of the Azure migration but when debugging I found it was because of this issue.

    The app is universal and the phone app is still correctly working.

    If it is necessary this is my app: https://www.microsoft.com/en-us/store/apps/eclipse-manager/9wzdncrdjmh1

    Thank You

    • Edited by r.c.byrne Friday, December 18, 2015 10:27 PM
    • Merged by Justin H. - MSFT Tuesday, December 22, 2015 4:53 PM Same Issue
    Friday, December 18, 2015 10:26 PM
  • We have exactly the same problem. We have had dozens of angry customers contact us in the last 24 hours complaining that their in app purchases are no longer being recognised.

    We have debugged through the code and can see that the CurrentApp.LicenseInformation.ProductLicenses collection does contain the in app purchase details however the IsActive property is set to False when it should be True.

    We raised a support request with Microsoft but their response was to suggest that we unpublish the in app purchase and then republish it. However they said this was a fix that works "in some cases" which isn't very helpful.

    Their other suggestion was that we should tell our customers to contact the Microsoft Store for a refund and then re-purchase the app. Again this is a completely ridiculous solution since we have thousands of customers with this in app purchase.

    Saturday, December 19, 2015 9:18 AM
  • Same problem. I think it's a bug of system/store. You mean we should repair it ourselves?  There will not be any system update?

    • Edited by Exilerrr Sunday, December 20, 2015 9:41 AM
    Sunday, December 20, 2015 9:38 AM
  • Same problem. This is a very serious problem and many of my users are giving bad reviews on Windows Store. Hope they'll fix it ASAP.
    Sunday, December 20, 2015 10:12 AM
  • I just wanted to start a new thread regarding the problem. Seems that I'm not alone.

    I just released a new update of my UWP app Action Note. Everything was working fine before this update yesterday in the evening, but to be honest I'm not sure if this was a problem due to the update.

    All I know is that I observe the same behaviour. IAP's are not active anymore after updating / reinstalling the app. And even when a user buys the IAP, it says it was successful, but IsProductActive still returns false and after restarting the app, the IAP is inactive again.

    I just published another update (of exactly the same version of the app) and just hope this is fixing the issue...

    This issue is very critical, because it effect those customers that have PAYED MONEY for our apps!

    Sunday, December 20, 2015 11:14 AM
  • Out of desperation, we re-submitted our IAPs to the store on Friday afternoon.  When we went to update them, we noticed that the portal was displaying a 'last modified' date that was incorrect (we haven't modified our IAPs in well over a year but it was displaying a date from Dec 2015).  When we looked at the details, we noticed our IAP was "available in 132 of 145" markets and one of our IAPs had an "invalid description" because it was over 200 characters.  We resubmitted with our IAP available in just the same market as our app and a shortened description.  So far, we have received far fewer user complaints and 2 users wrote us to say that everything "was back to normal".

    You might try resubmitting your IAPs and make sure your markets and description are set correctly.

    The support and response from Microsoft has been abysmal.

    Sunday, December 20, 2015 1:40 PM

  • You might try resubmitting your IAPs and make sure your markets and description are set correctly.

    The support and response from Microsoft has been abysmal.

    I will give it a try. Resubmitting my app did not work.

    But in my case, there was not such a problem with the IAP in the DevCenter, so all 242 countries have been selected, the descriptions of every country was shorter than 200 chars and there was no "last modified" IAP. But nevertheless I give it a try, because except that I have no idea what to do, but wait for Microsoft to fix the issue.

    I will write more as soon as the updated IAP is available...

    Update: Unfortunately, updating the IAP also does not help.

    Sunday, December 20, 2015 3:22 PM
  • We are experiencing the same issue with a few of our apps and they always occur after an update.  This needs to be fixed by Microsoft asap as it is causing our users grief after paying money to purchase the IAP.  Not to mention people are leaving bad reviews as a result.
    Tuesday, December 22, 2015 3:52 AM
  • This is happening with 2 of our apps as well. This has caused us hundreds of customer service inquiries and dozens of negative reviews since 12/18/2015. Please fix this ASAP!!!!
    Tuesday, December 22, 2015 4:53 AM
  • The problem seems to be fixed. At least in my app, the IAP is finall working again. Unfortunately, users have to activate the IAP manually even after reinstalling the app. I'm still not very happy about it. And I would be still very interested in the cause of this issue.
    Tuesday, December 22, 2015 1:58 PM
  • The problem seems to be fixed. At least in my app, the IAP is finall working again. Unfortunately, users have to activate the IAP manually even after reinstalling the app. I'm still not very happy about it. And I would be still very interested in the cause of this issue.
    This fix is not sufficient.  Microsoft needs to remove any negative reviews caused by THEIR issue.
    Tuesday, December 22, 2015 2:23 PM
  • Exactly the same problem is now affecting our Windows Phone app as well.

    Does anyone from Microsoft actually look at these forums? There have been many reports of exactly the same problem since last Friday with many developers complaining about upset customers and there has not been a single response from Microsoft. Unbelievable.

    • Edited by rb987654 Tuesday, December 22, 2015 5:01 PM
    Tuesday, December 22, 2015 4:41 PM
  • Hello All,

    If you are still experiencing this issue, please create a request with us here through your developer account so we may assist you appropriately. Thank you!


    Please attempt creating the request in an alternate browser with a cleared cache to get through the received error.

    Tuesday, December 22, 2015 4:49 PM
  • I had attempted to submit a support ticket with problem type "Apps and Windows Store" and with a category of "reporting a problem" and I get the error message you see in the screen shot.  On Friday, 12.18.2015, when I submitted a ticket with problem type "Support for writing apps" and a category of "Microsoft APIs", I got all the way to the final billing screen and received a different error message.  I tried opening a ticket this morning and it finally succeeded.

    Most of our users are reporting situation is back to normal now that we resubmitted our IAPs.  Users with an existing installation must still tap the "upgrade" button for the IAP license to be recognized.  New users do not appear to be affected.

    Tuesday, December 22, 2015 5:13 PM
  • Hello,

    I am having the same issue with my application, also getting many angry email from customers. Is there any ETA on a fix from Microsoft? This is a severe issue



    Tuesday, December 22, 2015 8:51 PM
  • Hi, I have thesame problem with IAP not available to customers who already have bought it.

    This seems to have happened after I upgraded to VS2015 Update 1 using 0.0.10586. I have sent a support case to Microsoft and hope for response within 24 hours.

    Tuesday, December 22, 2015 10:51 PM
  • I have the exact same issue :


    returns false for bought durable IAP.

    Tuesday, December 22, 2015 11:34 PM
  • I have the same problem, after purchasing IAP is not active on Win10 and active on Win8.1, my app W8.1 C#/XAML project.
    Tuesday, December 22, 2015 11:47 PM
  • I had the same problem. I recommended a consumer to use wsreset.exe and it did help.

    But well, a fix is something else.

    Tuesday, December 22, 2015 11:47 PM
  • I had the same problem. I recommended a consumer to use wsreset.exe and it did help.

    But well, a fix is something else.

    tried wsreset.exe on my win10, did not help.
    Tuesday, December 22, 2015 11:55 PM
  • Yes, it will restore somtimes, but if reinstall/update , it will lost again and again.
    • Edited by Exilerrr Wednesday, December 23, 2015 12:52 AM
    Wednesday, December 23, 2015 12:47 AM
  • Yes, I reported a similar issue a week ago:


    I have a support ticket with Microsoft for it (started by starting a chat and the chat rep opened it rather than me going through the category picking (shame no category for IAP). That said, still not fixed and been > 1 week since I had any useful feedback on it.

    Wednesday, December 23, 2015 6:57 AM
  • This "solved" the issue for me:

    1. update all IAPs

    2. restart the app

    3. press the "buy" button for an already owned IAP again

    Far from being a perfect resolution, steps 2-3 are difficult for users to notice without help.

    • Proposed as answer by Andev Wednesday, December 23, 2015 10:08 AM
    Wednesday, December 23, 2015 9:25 AM
  • It looks like one change is they turned on enforcing description limits. 3 of my IAP's had long descriptions. I'm hoping this helps. 

    It's frustrating because they really need to alert us if there are changes like that and we have IAP products that will fall foul of the new rules.

    One thing I just realized is that I updated one of these IAP options when I first saw the issue, with no problems. This means that 1. They started enforcing the 200 char rule in last two weeks, and 2 . the updates to my IAP are unlikely to fix the issue.

    That said, at least something must work. I have 9 IAP options visible in my "get more features" screen, and I get 7 error messages on launch of that screen


    Looks like updating those IAP products with too long a description actually made things worse. Now when I open the get features screen under windows 10 mobile I get 9 errors.

    • Edited by bluechrism Wednesday, December 23, 2015 6:04 PM
    Wednesday, December 23, 2015 2:27 PM
  • I disagree, microsoft should not touch reviews, people that did them should remove them but if you let microsoft do it then reviews will become pointless. Microsoft needs to up their game cause this is not fair to customers and developers.  Its also a old issue I got 2-3 months ago so getting it now so late on in the win 10 development sucks.
    Wednesday, December 23, 2015 2:56 PM
  • I tried this, but didn't work for my app. I released my app just 2 days ago, and because of this issue, I am not yet publicizing my app.

    Hope MS fixes it soon.


    Wednesday, December 23, 2015 5:08 PM
  • Updating the IAP's led to error's on the few that were not previously affected for me, and trying to buy any of them it says the product is unavailable (under windows 10 mobile). It may be the bugs we have are slightly different, but I'm not sure I would follow this solution.
    Wednesday, December 23, 2015 6:07 PM
  • Here is another victim of this weird behavior. I have never used IAPs before and just started a few days ago trying it out only to find that the "ProductLicenses" dictionary never becomes populated, and so trying to access IsActive throws an exception. On the other hand what works is to use CurrentApp.GetProductReceiptAsync("productid"). That will return an xml receipt if the IAP is purchased, else throw an exception. So the store knows about the IAP being purchased or not, but something fails populating "ProductLicenses" or something.

    Jan Andersson

    Friday, December 25, 2015 7:29 PM
  • Just realised  that I've had no purchases on my app since the 18th of December! :( App is telling me that the IAP cannot be found, I'm trying as suggested doing a dummy update of the IAP, hopefully that'll fix it.

    Update: Updating the IAP but not changing anything appears to have made it work now...

    • Edited by AL3XT3CH Friday, December 25, 2015 9:20 PM
    Friday, December 25, 2015 8:16 PM