locked
LightSwitch options missing from Visual Studio 2013 RRS feed

  • Question

  • After upgrading to VS2013 Update 1...I now seem to have lost the right click options for my lightswitch project. I don't get any option to add a screen etc. I can however still update datasource by right clicking on the datasource and the lightswitch designer still seems to be working.

    Please please please somebody help!


    Also, when I right click the main project file, the option to Add New Client is missing too.
    • Edited by agupta80 Monday, February 3, 2014 8:14 AM More information...
    Monday, February 3, 2014 8:10 AM

Answers

All replies

  • Hi,

    You likely have corruption in your project files.

    Which version did you upgrade from?

    Which client(s) are you using?

    Does a new project created with VS2013 Update 1 work fine?

    Does your upgraded project fail to rebuild?

    Any error messages from the above checks...


    Dave Baker | AIDE for LightSwitch | Xpert360 blog | twitter : @xpert360 | Xpert360 website | Opinions are my own. For better forums, remember to mark posts as helpful/answer.

    Monday, February 3, 2014 10:23 AM
  • Hi,

    You likely have corruption in your project files.

    Which version did you upgrade from?

    Which client(s) are you using?

    Does a new project created with VS2013 Update 1 work fine?

    Does your upgraded project fail to rebuild?

    Any error messages from the above checks...


    Dave Baker | AIDE for LightSwitch | Xpert360 blog | twitter : @xpert360 | Xpert360 website | Opinions are my own. For better forums, remember to mark posts as helpful/answer.

    Hi Dave,

    Thank you for your prompt reply.  I wish there were a way to diagnose which project file (& why) is corrupted.  But anyway...I think I've narrowed it down to just the HTMLClient having the issues...The Silverlight client and the related server project seem fine.

    Answers to your questions:

    1) Upgraded from Visual Studio 2013 (which I had upgraded from Visual Studio 2012).  Now, in hindsight, I don't believe that since I had upgraded from VS2012, I had ever needed to add a new screen, so this issue may have been present prior to Update 1.  I have no way of knowing.

    2) I am using both the Silverlight and HTML clients

    3) New project with VS2013 U1 works fine

    4) No, project rebuilds fine, hence the reason for the late noticing of the anomaly on my part.

    5) No error messages that I can recall or have seen.

    FWIW, I have commenced the process of comparing the newly created project file(s) with my current versions to see what is different and hopefully will get some resolve or something more to report back!

    Monday, February 3, 2014 10:37 AM
  • Hi,

    Check this thread to see if that is the problem:

    Visual Studio 2012 Update 3 -> 2013 (RTM) There is no designer support for this file when opening tables (.lsml) files in VS 2013

    The 'LightSwitchVersion' version problem :)


    Dave Baker | AIDE for LightSwitch | Xpert360 blog | twitter : @xpert360 | Xpert360 website | Opinions are my own. For better forums, remember to mark posts as helpful/answer.

    • Marked as answer by agupta80 Monday, February 3, 2014 11:06 AM
    Monday, February 3, 2014 11:02 AM
  • Hi,

    Check this thread to see if that is the problem:

    Visual Studio 2012 Update 3 -> 2013 (RTM) There is no designer support for this file when opening tables (.lsml) files in VS 2013

    The 'LightSwitchVersion' version problem :)


    Dave Baker | AIDE for LightSwitch | Xpert360 blog | twitter : @xpert360 | Xpert360 website | Opinions are my own. For better forums, remember to mark posts as helpful/answer.


    This fixed my problem Dave, thank you!
    Monday, February 3, 2014 11:06 AM