none
.swf not showing in IE9 RRS feed

  • Question

  • I am having difficulty with getting a rotating flash animation that has links embedded in it to show up in IE9.  It shows up in Firefox and Chrome and operates correctly.  How do I work around this? Here is the code if that helps: 

    <div style="position: absolute; width: 100px; height: 100px; z-index: 0; left: -39px; top: 102px;" id="layer2">
       <object id="flash2" class="style2" data="images/front page rotate menu.swf" style="width: 636px; height: 362px" type="application/x-shockwave-flash">
       </object>
       </div>

    Thank you for any and all assistance.

    Monday, March 19, 2012 6:30 PM

All replies

  • Publish it and provide a link.  What we could do is tell you if it plays for us in IE9, which would narrow down your issue a something local to you.

    Otherwise, it's a topic for a Flash forum, or a google search. 

    (I'll mention an obvious issue, which probably has nothing to do with your IE9 problem: Don't use spaces in file names for the web, as you are doing above for your .swf file.)

    Monday, March 19, 2012 6:40 PM
  • I fixed the spaces in the file name and as you suspected, it didn't fix my issue, but I will pay more attention to such things moving forward. 

    I published it on to the web and the lo & behold it works!  It didn't work in the preview for IE9 so I was reluctant to publish.  Thank you for your help. 


    Jason Upton

    Monday, March 19, 2012 7:01 PM
  • FWIW, if you preview using the file system a lot of active content is blocked. If you use Site > Site Settings > Preview with use the testing server for "all pages" selected then active content will run when you Preview in Browser.

    Free Expression Web Tutorials
    For an Expression Web forum with without the posting issues try expressionwebforum.com

    Wednesday, April 4, 2012 10:48 PM