locked
how to test multiple user name and password in web performance testing RRS feed

  • Question

  • I tried using "add data source" by using csv files, but while running the web performance test the parametrized values from the csv files are not getting detected(even though on clicking the promote dynamic parameters to web test parameters)

    can u help me in running multiple username and password?


    Thursday, May 19, 2016 4:12 PM

Answers

  • Hi vivin sundar,

    Do you get any error message when getting data from csv file failed? Please share the detailed error message here, which can help us understanding the problem.

    After add data source to our Web Performance Test, we need to bind the data to parameters that used in Web Performance Test. The detailed steps about how to bind the data to parameter, please refer to following link.

    https://msdn.microsoft.com/en-us/library/ms243142.aspx

    In addition, please provide some description for your situation about when you use the username and password and how the process that you do.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Proposed as answer by Weiwei Cai Wednesday, May 25, 2016 9:10 AM
    • Marked as answer by Weiwei Cai Friday, May 27, 2016 8:50 AM
    Saturday, May 21, 2016 5:12 AM
  • The Promote Dynamic Parameters button has nothing to do with data sources you need to find the form post parameters and bind them to the data source or go onto set credentials and bind it there depending on your authentication method.
    • Proposed as answer by Weiwei Cai Wednesday, May 25, 2016 9:10 AM
    • Marked as answer by Weiwei Cai Friday, May 27, 2016 8:50 AM
    Tuesday, May 24, 2016 2:14 PM

All replies

  • Hi vivin sundar,

    Do you get any error message when getting data from csv file failed? Please share the detailed error message here, which can help us understanding the problem.

    After add data source to our Web Performance Test, we need to bind the data to parameters that used in Web Performance Test. The detailed steps about how to bind the data to parameter, please refer to following link.

    https://msdn.microsoft.com/en-us/library/ms243142.aspx

    In addition, please provide some description for your situation about when you use the username and password and how the process that you do.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Proposed as answer by Weiwei Cai Wednesday, May 25, 2016 9:10 AM
    • Marked as answer by Weiwei Cai Friday, May 27, 2016 8:50 AM
    Saturday, May 21, 2016 5:12 AM
  • The Promote Dynamic Parameters button has nothing to do with data sources you need to find the form post parameters and bind them to the data source or go onto set credentials and bind it there depending on your authentication method.
    • Proposed as answer by Weiwei Cai Wednesday, May 25, 2016 9:10 AM
    • Marked as answer by Weiwei Cai Friday, May 27, 2016 8:50 AM
    Tuesday, May 24, 2016 2:14 PM
  • Sorry for the delay in replying...

    Now its working fine

    thanks for your effort

    Thursday, June 9, 2016 10:39 AM