locked
Send Mail Action repeatedly sending mail in SPD-2013 Workflow RRS feed

  • Question

  • Hi,

    I have designed simple SharePoint 2013 worklow in which I am sending mail at certain level. What happening sending mail action executes n number of times. Its sending mail again and again. here is glance of that workflow action.

    Stage:HOD Approval
    Wait for FormStatus to equal WHOD
    Set CurrentApprover to Current Item:HOD
    Email Current Item:HOD
    Wait for WaitForStatus to equal 4

    Transition to stage
     If Current Item:HODApprovalStatus equals Rejected
      Go to HOD Rejected
     Else
      Go to CH1 Approval

    Workflow continuously executes send mail : HOD. What might causing the issue ?

    Thanks in advance.

    Friday, January 29, 2016 6:02 AM

Answers

  • Hi Suhil Jisaheb.

    How do you set the workflow start option? If the workflow starts when an item is changed, then every change will trigger the workflow.

    Did other actions work repeatedly? Do you have a loop in your workflow that will redirect the workflow to the first stage? Please check the workflow.

    In addition, I suggest you adding some “log” action to troubleshooting the workflow.

    Best Regards,

    CY

    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Proposed as answer by Kuldeep Verma Thursday, February 11, 2016 7:49 AM
    • Marked as answer by Dean_Wang Monday, February 15, 2016 7:53 AM
    Monday, February 1, 2016 5:55 AM
  • Thanks Chris yuri for your response.

    I came to know that it was Mail Server issue.

    • Proposed as answer by Chris yuri Monday, February 15, 2016 6:34 AM
    • Marked as answer by Dean_Wang Monday, February 15, 2016 7:53 AM
    Thursday, February 11, 2016 7:04 AM

All replies

  • I just came to know that it is not application level issue. Because I have many more applications which are using Send mail actions. Same thing is happening with some of those application too. Workflow sends mail repeatedly.

    Please let me know if you have any idea regarding this as soon as possible.

    - Suhil Jisaheb.


    Friday, January 29, 2016 10:45 AM
  • Hi Suhil Jisaheb.

    How do you set the workflow start option? If the workflow starts when an item is changed, then every change will trigger the workflow.

    Did other actions work repeatedly? Do you have a loop in your workflow that will redirect the workflow to the first stage? Please check the workflow.

    In addition, I suggest you adding some “log” action to troubleshooting the workflow.

    Best Regards,

    CY

    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Proposed as answer by Kuldeep Verma Thursday, February 11, 2016 7:49 AM
    • Marked as answer by Dean_Wang Monday, February 15, 2016 7:53 AM
    Monday, February 1, 2016 5:55 AM
  • Thanks Chris yuri for your response.

    I came to know that it was Mail Server issue.

    • Proposed as answer by Chris yuri Monday, February 15, 2016 6:34 AM
    • Marked as answer by Dean_Wang Monday, February 15, 2016 7:53 AM
    Thursday, February 11, 2016 7:04 AM
  • Hi Suhil,

    Since you have found the cause, please mark it as answer.

    It will be helpful to others.

    Thanks for your understanding.

    Best Regards,

    CY


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, February 11, 2016 7:47 AM