none
ESP portal 2.1 in multiserver Environment giving Error ": The remote server returned an error: (403) Forbidden." RRS feed

  • Question

  • ESB Portal is working fine ,Once I deployed in MultiServer Environment ,I am able to browse all services except ESB portal.

    Event code: 3005 Event message: An unhandled exception has occurred. Event time: 5/15/2013 2:46:01 PM Event time (UTC): 5/15/2013 7:46:01 PM Event ID: 5fe40b0d2fad418c81272e4a198445b8 Event sequence: 4 Event occurrence: 1 Event detail code: 0 Application information: Application domain: /LM/W3SVC/1/ROOT/ESB.Portal-2-130131207603956926 Trust level: Full Application Virtual Path: /ESB.Portal Application Path: C:\Projects\Microsoft.Practices.ESB\ESBSource\Source\Samples\Management Portal\ESB.Portal\ Machine name: ServerNAme Process information: Process ID: 14228 Process name: w3wp.exe Account name: NT AUTHORITY\NETWORK SERVICE Exception information: Exception type: WebException Exception message: The remote server returned an error: (403) Forbidden. Request information: Request URL: https://localhost:443/ESB.Portal/Default.aspx Request path: /ESB.Portal/Default.aspx User host address: 127.0.0.1 User:----- Is authenticated: True Authentication Type: Negotiate Thread account name: NT AUTHORITY\NETWORK SERVICE Thread information: Thread ID: 5 Thread account name: NT AUTHORITY\NETWORK SERVICE Is impersonating: False Stack trace: at System.Net.HttpWebRequest.GetResponse() at System.ServiceModel.Channels.HttpChannelFactory.HttpRequestChannel.HttpChannelRequest.WaitForReply(

    Any help will be appriciated.

    Thanks,Chandra

    Wednesday, May 15, 2013 7:53 PM

Answers

  • Have you updated the Connection Strings to point at the remote SQL Server rather than the default local?

    Colin Meade (MCTS BizTalk Server) http://midheach.wordpress.com

    • Marked as answer by Pengzhen Song Wednesday, May 22, 2013 9:29 AM
    Monday, May 20, 2013 8:56 PM

All replies

  • Hi,

    In a MultiServer Environment, you should modify the authentication and authorization settings for the ESB management Portal.

    The default authorization group for standard access to the portal is <local_machine>\BizTalk Application Users. You can change this to a domain-level group, by editing the Web.config file for the portal.

    To specify a domain-level account, change the value of the <allow> element, as shown here.

    <authorization>     
      <allow roles="<your-domain-name>\BizTalk Application Users" />
      <allow roles="BizTalk Server Administrators" />
      <deny users="*" />
    </authorization>

    Greetings,

    Tomasso Groenendijk

    Wednesday, May 15, 2013 10:03 PM
  • Thanks for your reply Tomasso,

    I have already did those changes ,but still I am getting this error .

    Thursday, May 16, 2013 2:22 AM
  • Hi Chandra,

    Did you also add the users to the domain groups? Also the domain groups must have access to the ESBAdmin database.

    The ESBAdmin database contains the Universal Description, Discovery, and Integration (UDDI) information required by the portal. Two roles control access to the database:

    • ESBPortal. This role provides standard access level for portal users. By default, this role includes members of the BizTalk Application Users group.
    • ESBPortalAdmin. This role provides an elevated access level for portal administrators. By default, this role includes members of the BizTalk Server Administrators group.

    Greetings,

    Tomasso Groenendijk

    Thursday, May 16, 2013 11:34 AM
  • Yes ,I crossed verify all configuration ,but I couldn't find any difference here , It's is working fine  on my dev environment(single box) ,but  Once I configured in Test environment(multiple  boxes) it didn't work . One thing I did difference here from my local ,I created all databases in remote SQL box through script and assigned all relevant permissions.



    Thursday, May 16, 2013 12:29 PM
  • Have you updated the Connection Strings to point at the remote SQL Server rather than the default local?

    Colin Meade (MCTS BizTalk Server) http://midheach.wordpress.com

    • Marked as answer by Pengzhen Song Wednesday, May 22, 2013 9:29 AM
    Monday, May 20, 2013 8:56 PM