locked
<MyApp>.vshost.exe doesnt die RRS feed

  • Question

  •  Hello,

    When running a WPF Window app via the VS2008 debugger, and then killing the process, <MyApp>.vshost.exe.

    Well, the process still seems to linger (i let my machine run overnight and it was still there) (small size 17MB).

    When i try to attach the debugger to this process (perhaps to see what it is doing), i cant and i am told it is because
    the process is shutting down, which makes sense, having attempted to kill the process via Windows Task-Manager.

    I think it is better to kill <MyApp>.vshost.exe via the debugger (stop debugging).  
    But is there an alternative to kill <MyApp>.vshost.exe??

    Regard,s

    Paul
    Friday, May 30, 2008 11:03 AM

Answers

  • The <MyApp>.vshost.exe should still be running as long as visual studio is open.  Here is more information about the vshost.exe process.  To disable the hosting process, go into your project properties in the debug tab and uncheck "Enable the Visual Studio hosting process".
    • Proposed as answer by A.Carter Friday, May 30, 2008 1:44 PM
    • Marked as answer by Schwartzberg Monday, June 2, 2008 10:31 AM
    Friday, May 30, 2008 1:43 PM
  • For more information on the Visual Studio Hosting Process, see this page in the MSDN Library.

    • Marked as answer by Schwartzberg Monday, June 2, 2008 10:31 AM
    Friday, May 30, 2008 3:02 PM

All replies

  • The <MyApp>.vshost.exe should still be running as long as visual studio is open.  Here is more information about the vshost.exe process.  To disable the hosting process, go into your project properties in the debug tab and uncheck "Enable the Visual Studio hosting process".
    • Proposed as answer by A.Carter Friday, May 30, 2008 1:44 PM
    • Marked as answer by Schwartzberg Monday, June 2, 2008 10:31 AM
    Friday, May 30, 2008 1:43 PM
  • For more information on the Visual Studio Hosting Process, see this page in the MSDN Library.

    • Marked as answer by Schwartzberg Monday, June 2, 2008 10:31 AM
    Friday, May 30, 2008 3:02 PM