locked
TFS 2010 build: sometimes it doesn't generate the Binaries folder on the build PC RRS feed

  • Question

  • I have a VS 2010 solution containing only *.vcxproj (i.e. VC++ projects). The solution builds fine locally. However if built by TFS 2010 build, there is no Binaries sub-folder in the build PC. Only the Sources directory exist in the Build PC. Because of this issue, there is no output in the drop folder for the build.

    Why the Binaries folder is missing on the build PC in this case? BTW, I noticed that if the VS 2010 solution contains mixture of C# and C++ projects, the Binaries folder will be created, however there are still lots of binaries output missing from this folder.


    Jun HY
    Wednesday, August 17, 2011 9:17 PM

Answers

  • Hello Jun HY,

    Thanks for your post.

    To deal with your issue, please take a look at the Output Directory setting of your vcxproj project. Right-click your C++ project in the Solution Explorer and select Properties. Click Configuration Properties->General->Output Directory to make sure you have the value $(SolutionDir)$(Configuration)\ instead of  .\Debug .

    And I did a test on my machine, I have the Output Directory to be $(SolutionDir)$(Configuration)\, and I can got the Binaries folder on the TFS Build working directory.

    Thanks,


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, August 18, 2011 5:10 AM
    Moderator
  • Thank you, Vicky

     Your suggestion of using $(SolutionDir)$(Configuration)\ together with customizing build output folder solved my problem. Now the Binaries directory gets created all the time.


    Jun HY
    • Marked as answer by Jun HY Monday, August 29, 2011 4:56 PM
    Monday, August 29, 2011 4:56 PM

All replies

  • Hello Jun HY,

    Thanks for your post.

    To deal with your issue, please take a look at the Output Directory setting of your vcxproj project. Right-click your C++ project in the Solution Explorer and select Properties. Click Configuration Properties->General->Output Directory to make sure you have the value $(SolutionDir)$(Configuration)\ instead of  .\Debug .

    And I did a test on my machine, I have the Output Directory to be $(SolutionDir)$(Configuration)\, and I can got the Binaries folder on the TFS Build working directory.

    Thanks,


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, August 18, 2011 5:10 AM
    Moderator
  • Thank you, Vicky

     Your suggestion of using $(SolutionDir)$(Configuration)\ together with customizing build output folder solved my problem. Now the Binaries directory gets created all the time.


    Jun HY
    • Marked as answer by Jun HY Monday, August 29, 2011 4:56 PM
    Monday, August 29, 2011 4:56 PM