locked
Mapping data flow connection to SQL DB source RRS feed

  • Question

  • Hi all,

    There seems to be a breaking change regarding the connection of Azure SQL DB tables from ADF Mapping Data Flows. Before last Thursday (12.11.19), no problems occured, and the tables can be read without problems when called from a pipeline (lookup, select, etc, all work fine). However, since Thursday the following message appears in Debug mode (both when called from a pipeline, as well as when directly debugging the data flow):

    "DF-MSSQL_001 - Both user/pwd and tenant/spnId/spnKey cannot be specified"

    Unfortunately, the verbosity on this error does not help in resolving it, and neither did extensive search for the message or the error code.
    Were there any possible breaking changes released last week?

    Additional information: The respective SQL server is located in the same subscription as the ADF, and connected via service principal authentication (which is the only options for use with mapping data flows). The authentication from ADF works fine when testing, and when used in pipeline activities, so I don't think it is a problem with the service principal itself.

    Monday, November 18, 2019 12:30 PM

Answers

  • Hi mkolpin,

    Apologies for the inconvenience and thanks much for reporting this to us. ADF team has applied a hot fix and the issue is fixed now.

    Could you please verify and let us know if you notice anymore issues? 

    Thank you

    If a post helps to resolve your issue, please click the "Mark as Answer" of that post and/or click Answered "Vote as helpful" button of that post. By marking a post as Answered and/or Helpful, you help others find the answer faster.

    • Marked as answer by mkolpin Tuesday, November 19, 2019 8:29 AM
    Tuesday, November 19, 2019 12:16 AM

All replies

  • Hi mkolpin,

    Apologies for the inconvenience and thanks much for reporting this to us. ADF team has applied a hot fix and the issue is fixed now.

    Could you please verify and let us know if you notice anymore issues? 

    Thank you

    If a post helps to resolve your issue, please click the "Mark as Answer" of that post and/or click Answered "Vote as helpful" button of that post. By marking a post as Answered and/or Helpful, you help others find the answer faster.

    • Marked as answer by mkolpin Tuesday, November 19, 2019 8:29 AM
    Tuesday, November 19, 2019 12:16 AM
  • Thanks for the quick fix!

    I checked again, and can confirm that the error is now resolved!

    Tuesday, November 19, 2019 8:29 AM
  • Hi mkolpin,

    Good to know your issue is resolved. Thank you for confirming. 

    Thank you

    If a post helps to resolve your issue, please click the "Mark as Answer" of that post and/or click Answered "Vote as helpful" button of that post. By marking a post as Answered and/or Helpful, you help others find the answer faster.

    Tuesday, November 19, 2019 6:22 PM