none
Visual studio update-extensions behind a proxy server

    Question

  • I'm using Visual studio 2015 inside our organization. I want to be able to use the Extensions and updates features but I always get a connection problem when I try to access the "online" or "update" section. We are behind a proxy server. The problem is related to the configuration of the proxy because the feature work well if I connect my pc on a direct internet connection. The proxy is managed by another organization and I don't know much about that subject. I need help on what I should say so they understand what they need to change. Does someone knows what configuration need to be put in place to make that VS feature works? thanks
    Wednesday, June 01, 2016 5:14 PM

Answers

  • Hi SpaceCS,

    As far as I know, Visual Studio using the IE engine by default. So whether the download using the IE proxy config file based on the IE itself. And current, there doesn't have such settings to allow Visual Studio to set the proxy config file and assign the specific url for Visual Studio.

    I suggest you modify the devenv.exe.config file to let the news and updates can be downloaded and then download the extensions from website through browser directly.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, June 09, 2016 2:25 AM
    Moderator

All replies

  • Hi SpaceCS,

    Please add your proxy server information in the devenv.exe.config file with following steps.

    1. Open the devenv.exe.config file as administrator which under the path  of "C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE".
    2. Find the "System.net" node in devenv.exe.config file which at the end of the file.
    3. Add "DefaultProxy" information under the "System.net" node, which is similar with following code.
    <system.net>
        <settings>
            <ipv6 enabled="true"/>
        </settings>
        <defaultProxy useDefaultCredentials="true" enabled="true">
            <proxy bypassonlocal="true" proxyaddress=http://your proxy server address />
        </defaultProxy>
    </system.net>

    Then please save this file and restart your Visual Studio to check whether you can update the extensions through the proxy server.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, June 02, 2016 6:49 AM
    Moderator
  • Hello,

    I already tried those option without any success. I tried it again just to make sure.

    With your option, nothing works (news fead, extensions, update).

    if I use:

    <system.net>
            <settings>            
                <ipv6 enabled="true"/>
            </settings>        
        </system.net>

    I only have the news fead and upadte working.

    if I use:

    <system.net>        
            <defaultProxy useDefaultCredentials="true" enabled="true">
                <proxy bypassonlocal="true" usesystemdefault="true" />
            </defaultProxy>        
            <settings>
                <ipv6 enabled="true"/>
            </settings>
        </system.net>

    Only the extensions are working.

    Note: we are not using the proxy server settings in Internet explorer config. We are using a config file for the proxy settings.

    What next?

    thanks

    Thursday, June 02, 2016 5:59 PM
  • Hi SpaceCS,

    >> we are not using the proxy server settings in Internet explorer config. We are using a config file for the proxy settings.

    As far as I know, Visual Studio through IE engine to download the news, extensions, updates. Please try access the news and the extensions, updates download site from IE browser directly to check whether they can be accessed by IE browser directly.

    If not, the problem should related to the proxy server on your environment, I suggest you contact the organization who provides this proxy server. Please try ask them add proxy server settings for IE to let it can access the download site.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, June 03, 2016 2:10 AM
    Moderator
  • There might be something about the route is using. The update are using the http protocol (and also the news). The extensions are using the https(443) protocol. Visual studio seems to be using the IE proxy config file for the update but not for the 443. It's using a different route. maybe this is what is causing the problem. Is there a way to force Visual studio to use IE proxy config file (wpad file) and tell VS to allow 443 for gsgallery.com and the other url VS is trying to connect to?

    thanks

    Wednesday, June 08, 2016 6:10 PM
  • Hi SpaceCS,

    As far as I know, Visual Studio using the IE engine by default. So whether the download using the IE proxy config file based on the IE itself. And current, there doesn't have such settings to allow Visual Studio to set the proxy config file and assign the specific url for Visual Studio.

    I suggest you modify the devenv.exe.config file to let the news and updates can be downloaded and then download the extensions from website through browser directly.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, June 09, 2016 2:25 AM
    Moderator