locked
I am not able to send Database mail over TLS 1.2 in SQL server 2012 RRS feed

  • Question

  • Hi,

    We upgraded our internal mail server with TLS 1.2 yesterday for security concern. So we upgraded our SQL Server 2012 (Web Edition) with latest SP3 -CU5 11.0.6544.0 (X64) to support TLS 1.2 for sending mail from database mail.  But we are not able send mail from DB mail profile (profile has our Internal mail server credentials and this is over TLS 1.2 only)


    After a lot of research on Microsoft Blogs, I did some changes on Registry as follows:


    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.2] 
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.2\Client] "DisabledByDefault"=dword:00000000 "Enabled"=dword:00000001 
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.2\Server] "DisabledByDefault"=dword:00000000 "Enabled"=dword:00000001 

    Still no luck.

    After that I applied another hot-fix "SQL11_SP3_GDR__TLS_x86" ((SP3-GDR) (KB3125246) - 11.0.6216.27 (X64) Jan 11 2016 18:22:37). Then also we were unable to send mails form our internal server which upgraded to TLS 1.2.

    We are getting below error:

    Message The mail could not be sent to the recipients because of the mail server failure. (Sending Mail using Account 2 (2016-09-23T10:51:35). Exception Message: Cannot send mails to mail server. (Failure sending mail.).

    Note: Earlier we used TLS 1.0 and TLS 1.1, we were able to send DB mail with 1.0 and 1.1 versions. 

    Environment:

    Microsoft SQL Server 2012 (SP3-GDR) (KB3125246) - 11.0.6216.27 (X64)

                    Jan 11 2016 18:22:37

                    Copyright (c) Microsoft Corporation

                    Web Edition (64-bit) on Windows NT 6.2 <X64> (Build 9200: ) (Hypervisor)

                    Windows Server 2012

    Please help me in this. 




    Friday, September 23, 2016 1:41 PM

All replies

  • as discussed on Facebook thread, please open support case with exchange team.

    Balmukund Lakhani
    Please mark solved if I've answered your question, vote for it as helpful to help other users find a solution quicker
    --------------------------------------------------------------------------------
    This posting is provided "AS IS" with no warranties, and confers no rights.
    --------------------------------------------------------------------------------
    My Blog | Team Blog | @Twitter | Facebook
    Author: SQL Server 2012 AlwaysOn - Paperback, Kindle

    Saturday, September 24, 2016 2:54 AM
  • Thanks Balamukund,

    Still I am facing same Issue. When I disabled TLS 1.2 everything is fine with TLS 1.1 and mails were sending but with TLS 1.2 we were not able to sending mails.

    Please help me on this as soon as possible. 

    Thanks in Advance.

    Saturday, September 24, 2016 4:03 AM
  • Did you figure out how to address this issue?

    Chad

    Monday, December 3, 2018 4:51 PM
  • Does anyone have an update for this? We are running SQL 2012 SP4 GDR, and cannot get TLS 1.2 working with dbmail. We have made .NET registry changes. We are trying to send mail through O365 (smtp.office365.com, Port 587). We are getting errors that say communication with server via TLS are failing.
    Wednesday, July 3, 2019 5:11 AM