none
Custom Form VBA Not Working After Update RRS feed

  • Question

  • I am having trouble with using VBA to open a website in the latest version of Outlook (1705 / 16.0.8201.2102, installed from 365 ProPlus). I have a custom form that has several buttons on it, with code that looks like this.

    Function AdminForm_Click()

    Set Web = CreateObject("InternetExplorer.Application")
    Web.Visible = TRUE
    Web.Navigate "http://intranet/admin/forms/adminform.asp"

    End Function

    So when the button is clicked, Internet Explorer opens up to the specified URL. This code has been working for 17 years but now in 16.0.8201.2102, when you click the button it does nothing. I found a workaround, in which you can open the Developer ribbon, click "Design This Form", and then click "Run This Form". After that the form relaunches and the button works as expected.

    This problem has come up on several computers all at once, and on all of them it was after the update to 16.0.8201.2102. Happens on both Windows 10 and Windows 7. I have tried it in Safe Mode, and it does not work there either. I have used the Office 2016 Deployment Tool to downgrade to 16.0.8201.2075, and confirmed that it works correctly in that version.

    So is this a bug in 16.0.8201.2102? Or has there been a change to where I need to be doing something differently? Is there better code for launching a URL from a custom Outlook form? Like I said I've been using this code since Outlook 2000, and kind of half-waiting for it to break with each new version.
    Tuesday, June 20, 2017 7:03 PM

Answers

All replies