locked
FileNotFoundException RRS feed

  • Question

  • Hi

    While executing load test I get an error FileNotFoundException and Could not find file 'c:\Cachedpages.xml'

    I have VSTS 2013 and all my agents are running good

    I also have a file name cachedpages.xml in C drive, but I still get the error.

    Has anyone come across this error and how to resolve ?

    Regards 

    Shridhar

    Tuesday, September 29, 2015 8:02 AM

Answers

  • In which computer's C: drive did you find the file? Is the file available on all the agents?

    Regards

    Adrian

    Tuesday, September 29, 2015 9:08 AM
  • I have the file on the controller machine.

    Resolved the issue, I recently created a new agent and on the new machine the file was missing.

    I placed the file now and the test is running. Thank you Adrian

    But why wasn't there in the first place on the new machine and how did it got created on the existing agent I am not sure, can you please let me know!

    Regards

    Shridhar

    Tuesday, September 29, 2015 9:49 AM

All replies

  • In which computer's C: drive did you find the file? Is the file available on all the agents?

    Regards

    Adrian

    Tuesday, September 29, 2015 9:08 AM
  • I have the file on the controller machine.

    Resolved the issue, I recently created a new agent and on the new machine the file was missing.

    I placed the file now and the test is running. Thank you Adrian

    But why wasn't there in the first place on the new machine and how did it got created on the existing agent I am not sure, can you please let me know!

    Regards

    Shridhar

    Tuesday, September 29, 2015 9:49 AM
  • >>

    I have the file on the controller machine.

    Resolved the issue, I recently created a new agent and on the new machine the file was missing.

    I placed the file now and the test is running. Thank you Adrian.

    >>

    Hi Shridhar,

    Do you mean that this issue has been resolved if you copy the file to your test agent machine?

    If this issue was resolved, you could mark the useful reply as the answer.

    >>But why wasn't there in the first place on the new machine and how did it got created on the existing agent I am not sure, can you please let me know!

    You know that one thread for one issue, it would be better if you open up a new thread
    for the new question. In this way, our discussion here will not deviate too much from the original issue. This will make answer searching in the forum easier and be beneficial to other community members as well.

    In addition, it would be better if you could share us more detailed message in your new thread, for example, which kind of test did you add to the load test? How did you set up the remote test in your side? Do you instal the VS, Test controller and test agent in three different machines?

    For remote tests, You know that The test controllers send the messages to the test agents, and actually the test agents run the tests. So if your tests really call certain files in your test method code like the coded UI test, the file would be in the test agent machine or the current test project machine, not the test controller machine. So the real issue would be related to the remote test configurations or how you really write you tests which were added to the load test. 

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, September 30, 2015 6:04 AM
  • Yes after placing the file on the new machine issue was not reproducible and I was able to initiate the test without any errors.

    Will create a new request for other query. Thank you Jack

    Regards

    Shridhar 

    Monday, October 5, 2015 5:58 AM