ASP .NET Published Website generates 404 error RRS feed

  • Question

  • User796929386 posted

    I've been programming in VB .NET seven years or so but have not done anything in ASP .NET yet. So we were in need of a simple website so I created it is ASP .NET, VS 2005. I create a page that takes some information and saves it to our SQL Server(2008) with an ODBC connection. This all works correctly when I run it through the IDE. I then right clicked the website and selected Publish website. I used the default settings.

    I then copied the folder and pasted into c:\inetpub\wwwroot\ on the machine I would be hosting the website. The machine is a Windows Server 2008 R2 Datacenter running Windows 7.  I Installed the Web Server (IIS) role.

    I then went into the IIS Manager and on Default Web Site I did and Add Virtual Directory, put in an alias, and set the Physical Path to the folder I copied to wwroot. I then switched the virtual directoy to an application. When I browse to the location or the aspx page I get an 404 "The requested resource is not available".

    I also tried adding it as a new website under Sites and that did not work either. Under this scenario however I get an "Internat unable to display the page webpage" error.

    It might be something really trivial since I haven't been trained in this but I've found a coulpe walkthroughs on the internat for publishing a website, follow them, and did not get the site to work.

    Friday, March 29, 2013 12:40 PM


  • User-691245060 posted

    Cross check your deployment steps with those in here - 



    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Saturday, March 30, 2013 1:04 AM
  • User-120949784 posted


    Here is the quick checklist:

    • Check the IIS settings.
    •  Application Pool and also check whether you are able to BROWSE the site from IIS or no.
    •  If required also check for permissions.
    • Are you using any Authentication Mode?
    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Saturday, March 30, 2013 1:18 AM

All replies