none
Dec CTP RRS feed

  • Question

  • Hi all,

    I have installed Dec CTP and the good news is that it seems
    there are no changes in the API - all of my programs recompiled without any problem.

    The bad news is that the problems that I had with Nov CTP are present in Dec CTP too.
    I am going to relist them:

    1. Camera transform affects hit test results: If the camera transform is not the identity, the hit test results are "distorted". It seems that the transform is not taken into account when converting the 2D hit point into the 3D ray.

    2. Trying to animate a property of a ModelVisual3D I get "Multi-step property paths may not be specified on an
    object of type 'System.Windows.Media.Media3D.ModelVisual3D'". The same with GeometryModel3D.
    The workaround was to go up on the tree and use a FrameworkElement (usually the Viewport3D) as the target name.
    But because I have some ModelVisual3Ds as the Children of another ModelVisual3D I cannot build the path - there is no dependency property (ChildrenProperty) for ModelVisual3D.

    3. I have some custom controls derived from Canvas. These controls are dinamically added in code and have to be animated
    using storyboards.
    I register their name using Application.Current.MainWindow.RegisterName(myControl.Name, myControl);
    but I still get the error "The name 'myControlName' could not be resolved in the name scope of 'MS.Internal.AppModel.RootBrowserWindow'"
    It's like the name is not registered at all, I have tried to register the name at different levels (Grid etc.) but to no avail.

    4. I have a list of custom objects to be presented as 3D objects in a listbox. I am using DataTemplate for this task and in the Triggers section I start an animation on mouse over. The error I get on mouse over is "The value of property 'Transform' in the path '(0).[0].(1).[1].(2).(3).(4)' points an immutable instance of
    'System.Windows.Media.Media3D.RotateTransform3D' which may not be manipulated.". I understand this is a known bug,
    but I was hoping to be fixed in Dec CTP.

    5. Superscript not working (see a previous thread).

    Thank you,
    Valentin

    Tuesday, December 20, 2005 2:32 AM
    Moderator

Answers