locked
Error: Application cannot be started. Contact the application vendor? RRS feed

  • Question

  • Hi,

    I have previously installed my LS application in my desktop wihtout any problem.  I was indeed satisfied because it was running fluently as expected.   Today I am visiting my installed project in and I'm encountering this error:

    upon clicking on the details I got this error summary:

    PLATFORM VERSION INFO
     Windows    : 6.1.7600.0 (Win32NT)
     Common Language Runtime  : 4.0.30319.17929
     System.Deployment.dll   : 4.0.30319.17929 built by: FX45RTMREL
     clr.dll    : 4.0.30319.17929 built by: FX45RTMREL
     dfdll.dll    : 4.0.30319.17929 built by: FX45RTMREL
     dfshim.dll    : 4.0.41209.0 (Main.041209-0000)

    SOURCES
     Deployment url   : file:///C:/Users/KharolJ/Documents/Visual%20Studio%202012/Projects/TMIS/TMIS/Publish/TMIS.application

    IDENTITIES
     Deployment Identity  : TMIS.application, Version=1.0.13.0, Culture=neutral, PublicKeyToken=0000000000000000, processorArchitecture=x86

    APPLICATION SUMMARY
     * Installable application.

    ERROR SUMMARY
     Below is a summary of the errors, details of these errors are listed later in the log.
     * Activation of C:\Users\KharolJ\Documents\Visual Studio 2012\Projects\TMIS\TMIS\Publish\TMIS.application resulted in exception. Following failure messages were detected:
      + Cannot activate a deployment with earlier version than the current minimum required version of the application.

    COMPONENT STORE TRANSACTION FAILURE SUMMARY
     No transaction error was detected.

    WARNINGS
     * The manifest for this application does not have a signature. Signature validation will be ignored.

    OPERATION PROGRESS STATUS
     * [1/31/2013 7:14:13 AM] : Activation of C:\Users\KharolJ\Documents\Visual Studio 2012\Projects\TMIS\TMIS\Publish\TMIS.application has started.
     * [1/31/2013 7:14:13 AM] : Processing of deployment manifest has successfully completed.
     * [1/31/2013 7:14:13 AM] : Installation of the application has started.

    ERROR DETAILS
     Following errors were detected during this operation.
     * [1/31/2013 7:14:13 AM] System.Deployment.Application.DeploymentException (SubscriptionState)
      - Cannot activate a deployment with earlier version than the current minimum required version of the application.
      - Source: System.Deployment
      - Stack trace:
       at System.Deployment.Application.SubscriptionStore.CheckMinimumRequiredVersion(SubscriptionState subState, AssemblyManifest deployment)
       at System.Deployment.Application.SubscriptionStore.CheckDeploymentSubscriptionState(SubscriptionState subState, AssemblyManifest deployment)
       at System.Deployment.Application.ApplicationActivator.InstallApplication(SubscriptionState& subState, ActivationDescription actDesc)
       at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)
       at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)

    COMPONENT STORE TRANSACTION DETAILS
     No transaction information is available.

     

    My question is: What causing this error and how to resolve it?

    KharolJ

    Wednesday, January 30, 2013 11:38 PM

Answers

  • Seems my click-once file was corrupted, I was suppose to reinstall the app but I having the same error upon clicking the "setup" file in my publish directory.

    I believe the only solution would be to re-publish and re-install  the app.

    kharolJ

    • Marked as answer by kharolJ Thursday, January 31, 2013 12:57 AM
    Thursday, January 31, 2013 12:56 AM