locked
Uninstall Lightswitch out-of-the browser (desktop) client issue RRS feed

  • Question

  • Hi All,
    I have Uninstall a Lightswitch out-of-the browser (desktop) client from end user PC, through Control Panel->Uninstall a program. Client app remove successfully. When I try to reinstall application again browser says {applicaitonname} has installed successfully. Please launch this application from the start menu. Whereas I do not see anything in the start menu. I went into c:\{username}\Documents\Microsoft\LightSwitch directory and deleted prior versions of this application from Manifests and Setting folders. Even this didn’t resolve the issue. Does anyone has this issue? This application is created using VS2012.

    Thanks,
    Suneel

    Thursday, August 29, 2013 12:47 AM

Answers

  • Hi,

    You have to clear the Silverlight folder. Then it will work:

    Users\username\AppData\local\Microsoft\Silverlight\OutOfBrowser\

    Delete your appfolder inside the \OutOfBrowser

    Do not delete the OutOfBrowser :)

    Regards

    Sven


    Sven Elm


    • Edited by Sven Elm Friday, August 30, 2013 10:49 AM
    • Marked as answer by SuneelK Friday, August 30, 2013 5:33 PM
    Friday, August 30, 2013 10:44 AM

All replies

  • Hi Suneel,

    According to your description, I’d like to suggest you clean and rebuild your current Project (Right-click > Clean, Right-click Rebuild respective) and see if that makes any difference at all.  


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Friday, August 30, 2013 9:45 AM
  • Hi,

    You have to clear the Silverlight folder. Then it will work:

    Users\username\AppData\local\Microsoft\Silverlight\OutOfBrowser\

    Delete your appfolder inside the \OutOfBrowser

    Do not delete the OutOfBrowser :)

    Regards

    Sven


    Sven Elm


    • Edited by Sven Elm Friday, August 30, 2013 10:49 AM
    • Marked as answer by SuneelK Friday, August 30, 2013 5:33 PM
    Friday, August 30, 2013 10:44 AM
  • Thanks Sven, It's working now.

    -Suneel

    Friday, August 30, 2013 5:33 PM
  • Double the thank you from me too, Sven.

    And, I just have to say, this is completely ridiculous.  God help me if my users ever need to uninstall.

    Thursday, September 10, 2015 9:31 PM