locked
Lightswitch table modification RRS feed

  • Question

  • Hi,

    I was happy with lightswitch ease of development. But I am very disappointed with its lack of flexibility. It happened multiple time, whenever, I add a new field in the table then add it in the screen, it started showing all kinds of error.  It has some kind of cache that is not cleared even after clean and rebuild. So the browser tries to show old screen data resulting in error.

    I am using Visual Studio 2012 Professional. Any help is appreciated.

    Thanks

    Musfiqur

    Friday, January 25, 2013 2:57 PM

All replies

  • Did you try to close the solution and then open it again?

    Friday, January 25, 2013 3:13 PM
  • I had a project that was complete. I added one more field.Then dragged that item to screen. Now I try to debug. it is showing: "Load operation failed for query 'GetAuthenticationInfo'. Exception of type 'System.ServiceModel.DomainServices.Client.DomainOperationException' was thrown.". 

    The screen is old and it is showing old screens that I deleted. To me it looks like mismatch problem between screen and database.So if you can suggest me to free up any screen related data from the machine, it would help.

    Friday, January 25, 2013 4:38 PM
  • Are you using the intrinsic data (LightSwitch tables)? Or are you attaching an external data source?

    If it's an external data source, are you right-clicking the data source & selecting Update Data Source?

    What you're describing is not normal, & doesn't happen regularly.


    Yann - LightSwitch Central - Click here for FREE Themes, Controls, Types and Commands
     
    Please click "Mark as Answer" if a reply answers your question. Please click "Vote as Helpful" , if you find a reply helpful.
     
    By doing this you'll help others to find answers faster.

    Saturday, January 26, 2013 12:50 AM
    Moderator