locked
Certified metro App not work with device Metadata

    Question

  • I first build a Metrop DeviceApp and a device metadata package (I use FX2 device access sample). They work well. I then do PROJECT->Store->Create App Packages to create a developer certified App package. After this, the App will get access denied error trying to connect to device driver.

    Even though I tried to use VS12 to rebuild App and deploy it, it will get "access denied" error.

    To make it work again, I modified .CSPROJ file to remove line 

    <PackageCertificateFile>CustomerDeviceAccess_TemporaryKey.pfx</PackageCertificateFile>

    The question is: how to make a certified metro App to work with device metadata package?

    Thursday, April 18, 2013 10:40 PM

Answers

All replies

  • Hi,

    I'll try to involve more experts in this case.


    Aaron
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, April 22, 2013 9:33 AM
  • Hi there,

    Check detail steps of creating and configure metadata on http://social.msdn.microsoft.com/Forums/en-US/tailoringappsfordevices/thread/05defdcd-1658-41cb-8d77-235ecfd194db

    Regards,

    Jenny

    • Marked as answer by wildcat9488 Wednesday, April 24, 2013 8:03 PM
    Wednesday, April 24, 2013 9:28 AM
  • My case is different. Metadata works with device access. It has problem with "Access Denied" only if I make my Metro App as developer certified Metro App. These are steps from Access OK --> Access Denied --> Access OK.

    1. Using Metadata authorization Wizard to create and submit metadata package.

    2. Build a Metro App (use FX2 device access sample) and deploy the App. Access OK.

    3. PROJECT->Store->Create App Packages to create a developer certified App package. Access Denied. Even though I rebuild and deploy it from VS12, access is still denied.

    4. Modify .CSPROJ file to remove line <PackageCertificateFile>CustomerDeviceAccess_TemporaryKey.pfx</PackageCertificateFile> (line is added by VS12 at step 3), rebuild and deploy through VS12. Access OK.

    The issue here is "a certified metro App does not work with device metadata package".

    I tried the steps mentioned in URL you listed. Issue is same. A strange senario is that I removed all cached files from ..\dmrcache\multiproc, and the metadat package from ..\DeviceMetadataStore\en-US,  reboot after taht, the device access is still working.

    Wednesday, April 24, 2013 8:38 PM