none
Report Viewer 2012 and Vista Service Pack 2 RRS feed

  • Question

  • Hello, I have a clickonce application that has a dependency on Report Viewer 2012. I have had a ton of trouble with this package.

    I also had to take a dependency on the SQLSysCLRTypes package. I just took a dependency on the x86 package as that is what the application is compiled to. However, the link in the package in the bootstrapper points to the wrong url! I had to open: C:\Program Files (x86)\Microsoft SDKs\Windows\v8.0A\Bootstrapper\Packages\SqlClrTypes_x86\en\package.xml and change the url to point to: http://go.microsoft.com/fwlink/?LinkID=239643

    I'm pretty sure that solved the SQLSysCLRTypes problem I was having.

    Now, when I try to install the application on a Windows Vista SP2 machine, after the prerequisites download, I get the message "Setup has detected that the publisher of file 'C:\Users\Admin\AppData\Local\Temp\VSD4746.tmp\ReportViewer\ReportViewer.msi' cannot be verified. Click OK to retry the download, or Cancel to exit setup."

    This only seems to happen on Vista. Windows 7 is a little more reliable, but has a failure every now and again.

    I should also mention that when I download the ReportViewer.msi directly from Internet Explorer, (from http://www.microsoft.com/en-us/download/details.aspx?id=35747 ), IE states that "ReportViewer.msi was reported as unsafe."

    Anyway, does anyone know the solution to this? I've spent days (off and on) on this problem and I'm not making any progress.

    Thanks in advance.

    -Jason




    • Edited by Jason Williams Monday, February 4, 2013 10:50 PM Fixing link
    Wednesday, January 23, 2013 10:47 PM

All replies

  • No one can offer an explanation or a fix? We've run into this with yet another one of our customers. Thankfully, we were able to walk them through installing Report Viewer 2012, by hand. Someone please help...
    Saturday, February 2, 2013 7:57 PM
  • You and me too. I just encountered the exact same issue on a Vista SP2 machine. I too had to install the report viewer manually... a huge pain considering the number of machines we will need to do this on! I have not yet tried it on a Windows 7 machine. So much for the convenience of ClickOnce.
    • Edited by dlcarpen Wednesday, February 6, 2013 8:02 PM
    Wednesday, February 6, 2013 8:01 PM
  • The same problem here, testing the deployment of a ClickOnce app upgrade with .NET Framework 3.5 SP1 and Report Viewer 2012, on a virtualized XP SP3.

    Any news ?


    Marco

    Friday, March 8, 2013 3:58 PM
  • So, here's what we just figured out... The msi at this link (http://www.microsoft.com/en-us/download/details.aspx?id=35747) has the "unsafe software" setting set "On" in the msi. That's what is triggering the "ReportViewer.msi was reported as unsafe." message after the download. It can be disabled by right clicking on the msi. Under the "General", click the "Unblock" button and then click "Apply". That will allow you to manually install the viewer.

    Before we figured this out, we could force the thing to install on our Windows 7 machines by launching the msi and ignoring the message. On our Windows Vista machines, we wouldn't get any error message at all. You could double click the msi, it would flash once and then do nothing. No errors, no nothing.

    Unfortunately, until someone at Microsoft rectifies this, we won't be able to use the "Download prerequisites from the components vendor's web site" option in our ClickOnce applications. One alternative would be to put the msi on a server somewhere and the use the "Download prerequisites from the following location" option. That's what we're doing. 


    • Edited by dlcarpen Friday, March 8, 2013 7:23 PM
    Friday, March 8, 2013 7:18 PM
  • dlcarpen, thank you for the hint...

    ...but I thought the "zone information" was set at download time by the Attachment Manager, although you're saying that copying the unblocked msi on another server (outside the client network, I suppose) and pointing the ClickOnce setup to it you solved this issue ?

    This is confusing me, am I right ?

    Attachment Manager


    Marco


    Saturday, March 9, 2013 7:33 AM
  • From what I can tell, unblocking the MSI doesn't fix this particular problem. You can manually download the file, unblock it, and then tell Vista to install the MSI even though it is from an untrusted publisher, but that doesn't fix the problem of automating the package's installation.

    Perhaps putting the MSI on your own server; inside of your network, would keep the "Blocked" bit from being flipped (since you would be transmitting it across the Intranet zone instead of the Internet zone). If that fixes your problem, I'm happy for you. However, I'm publishing to a internet server and this problem is still plaguing us.

    Come on Microsoft, please read your forums and let us know what we're doing wrong.

    Thanks to everyone for looking/reading.

    Saturday, March 9, 2013 11:58 PM
  • I am suffering from this same issue.  Please Help Microsoft!!
    Tuesday, April 16, 2013 2:13 PM
  • This just keeps getting better and better. Now, Microsoft has broken the bootstrapper for every version of Windows by breaking it's original link (http://go.microsoft.com/fwlink/?LinkID=217022). I'm very frustrated with this entire issue.

    Is there an updated bootstrapper somewhere?

    Wednesday, October 16, 2013 7:04 PM
  • We continue to have major problems with this package. Vista will never install ReportViewer.msi automatically. You always have to manually install it.

    I also have a client that is having trouble manually installing it because it won't detect the SQL CLR objects are installed on his Vista machine.

    Has anyone found a solution?

    Wednesday, April 30, 2014 2:38 PM
  • We have the same issue with ReportViewer 2012 included as dependency in Microsoft's Bootstrapper. The reason seems to be in SHA256 signature used to digitally sign the package. This type of signature cannot be validated on Vista SP2 / Server 2008, even with the latest updates installed. This is very unfortunate, as these platforms are officially supported for MSSQL 2012, including ReportViewer.

    The solution as we see it is to replace the signature (re-sign the package) with the SHA1-based certificate from the trusted provider, if you can afford it (AuthentiCode certificates are expensive), and update the product.xml accordingly. This won't work for Web installers (where dependencies are downloaded), but will help with Offline ones.

    EDIT: It appears it is impossible to re-sign already signed MSI package. However, nothing can prevent one from creating an SFX wrapper around MSI, which would run msiexec when extracted (7zip SFX mod can easily do it). Then you sign the SFX and include it in bootstrapper.


    • Edited by denis-gz Friday, February 5, 2016 4:14 PM Note added
    Monday, February 1, 2016 5:21 PM