none
System.Data.DataSetExtensions 3.5 vs 2.0 RRS feed

  • Question

  • Hi,

    I have created an application in .net; using Microsoft Visual basic 2008 express edition. I have used reference System.Data.DataSetExtensions 3.5.

    I need to build my application with target frameowk 2.0 as target PCs have .net framework 2.0 installed.

    Problem is: When i go to advance compile option and select target framework as 2.0 then i cannot publish the application. If i select 3.5 then i cannot install the application on target PCs as they do not have 3.5 framework. (Niether i can install 3.5 framework in target PCs).

    Any suggessions.

    Thx!
    Gaurav 
    Monday, August 24, 2009 1:11 PM

Answers

  • Hi Bossvb,

    Thank you for your post.

    When i go to advance compile option and select target framework as 2.0 then i cannot publish the application.  If i select 3.5 then i cannot install the application on target PCs as they do not have 3.5 framework. (Niether i can install 3.5 framework in target PCs).

    System.Data.DataSetExtensions is the class library that based on .NET Framework 3.5.
    See: http://msdn.microsoft.com/en-us/library/system.data.datatableextensions.aspx
    If we use this reference, we need to build our application on .NET Framework 3.5 instead of .NET Framework 2.0.
    So you cannot change the target framework from 3.5 to 2.0.

    To apply your application, please upgrade .NET Framework to 3.5 on the target PCs.

    Hope this helps. If you have any concern, please feel free to let me know.

    Best regards,
    Yichun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by YiChun Chen Monday, August 31, 2009 7:16 AM
    Wednesday, August 26, 2009 7:07 AM