locked
Reports stop working after 45-180 mins RRS feed

  • Question

  • User-2014199942 posted

    Hi,

    Using CR13.0.2 in Visual Studio 2008.

    Just upgraded from 10.5 to 13.0.2 When we now deploy the asp.net website to IIS7 the reports all run fine for a period of time (45 to 180 mins) then they all stop working and I get the Load Report failed error message. If I then recycle the application pool they all start working again.

    I have tried runing app pool as local serve. Upped the PrintJobLimit to 300 but nothing has worked. I guess there is some limit on the number of reports it runs before falling over but I can't find any limiting settings anywhere.

    It all worked fine under 10.5. Any ideas or pointers where to look?

    Tuesday, December 20, 2011 6:52 AM

All replies

  • User1196771204 posted

    hi robh_52,

    Based on the issue you described here, it seems that crystal report is not setup properly on your deployment server. There are several requirements to run Crystal Report:


    1. Please make sure the CR version installed on the server matches the one you use on your application/website
    2. Please make sure that the assemblies of the CR installed on the server are referenced correctly on your web.config
    3. Please make sure you set the application pool of your application to operate under LOCAL SERVICE permission
    4. Please make sure FULL TRUST mode is enabled on your operating folder
    5. Please make sure crystalreportviewer and aspnet_client folders are copied to your operating folder.

    I have been using Crystal Report for a while. I have also tried the latest Crystal Report for VS 2010 and initially, I experienced the problem like you do now. By following all the steps above, your CR will certainly work fine. Should you still have problems, you can consider hosting it with asphostcentral.com. For details to solve your issue, you can check here

    If you run this report on a shared server, you must always make sure that the server is not overloaded.

    Please mark this response as an "answer" if it helps you. Thanks heaps!

    Wednesday, December 21, 2011 1:21 AM