none
"docker ps" hangs, cannot stop docker service, server hangs on restart RRS feed

  • Question

  • I've been happily tooling along, building a dockerfile, and generally exploring and learning with TP5 (my first container and docker experience), and I've run into a bit of a snag. At some point, stuff sort-of stopped working. Here are the symptoms:

    • When I run a container with --interactive --tty, and the main process ends, I do not get returned to the command line.
    • "docker ps" simply hangs, with no output at all
    • The docker service cannot be stopped. To be clear, the service stops, but the dockerd process continues to run.
    • I cannot remove C:\ProgramData\docker because the "windowsfilter" folder cannot be removed. The error states "There is a mismatch between the tag specified in the request and the tag present in the reparse point". I do not know what this means.
    • Attempting to restart the computer results in a hang. If I power cycle the machine, it comes back for a while, but at some point will stop working.

    Any idea what the deal is? If I uninstall the container feature and reinstall it, will that get me back to a clean slate?



    • Edited by godefroi Thursday, August 18, 2016 9:26 PM
    Thursday, August 18, 2016 9:25 PM

All replies

  • More information: uninstalling the container feature (and removing the docker service) do NOT allow me to remove C:\ProgramData\docker (if that would even help). A hard power cycle is the only way to "recover" the machine. I created a new VM and tried again, this time with the rc2 version of docker from https://test.docker.com/builds/Windows/x86_64/docker-1.12.0.zip (Docker version 1.12.0, build 8eab29e), with no better results.
    Friday, August 19, 2016 5:18 PM
  • One more piece of information, almost certainly relevant. In my dockerfile, I am using ENTRYPOINT to execute a powershell script that executes a couple commands. One of these commands uses SqlPackage.exe to deploy a .dacpac file. If this deploy succeeds, the container hangs when I exit, and after that, "docker ps" and friends will no longer function. If SqlPackage.exe fails (for whatever reason), then the container exits normally and the issue is not observed.
    Friday, August 19, 2016 5:41 PM
  • Can you share some more info on the specific image and docker versions are? I suspect that moving to a newer Docker version (v1.12 final or v1.13) may help since there have been a lot of bugfixes since TP5 went out.

    - docker version

    - docker images

    - wmic qfe

    Another thing you can try when Docker is hung is using Get-ComputeProcess and Stop-ComputeProcess on TP5 to terminate the container. If that works, that can help narrow it down further.

    Thanks!
    Patrick

    Monday, August 29, 2016 7:56 PM
  • Thanks for taking a look. 

    PS> docker version
    Client:
     Version:      1.12.0
     API version:  1.24
     Go version:   go1.6.3
     Git commit:   8eab29e
     Built:        Thu Jul 28 21:15:28 2016
     OS/Arch:      windows/amd64
    
    Server:
     Version:      1.12.0
     API version:  1.24
     Go version:   go1.6.3
     Git commit:   8eab29e
     Built:        Thu Jul 28 21:15:28 2016
     OS/Arch:      windows/amd64

    PS> docker images
    REPOSITORY                    TAG                 IMAGE ID            CREATED             SIZE
    microsoft/windowsservercore   latest              02cb7f65d61b        10 weeks ago        7.764 GB

    PS> wmic qfe
    Caption                                     CSName          Description      FixComments  HotFixID   InstallDate  InstalledBy          InstalledOn  Name  ServicePackInEffect  Status
    http://support.microsoft.com/?kbid=3172729  SLC-DEV-S16P-2  Security Update               KB3172729               NT AUTHORITY\SYSTEM  8/27/2016
    http://support.microsoft.com/?kbid=3173423  SLC-DEV-S16P-2  Update                        KB3173423               NT AUTHORITY\SYSTEM  8/27/2016
    http://support.microsoft.com/?kbid=3176494  SLC-DEV-S16P-2  Security Update               KB3176494               NT AUTHORITY\SYSTEM  8/27/2016

    I can update to a newer version of Docker 1.12 or 1.13 (where should I be downloading it from?) and give it a try tomorrow.

    Monday, August 29, 2016 9:54 PM
  • So, oddly enough, I just attempted to recreate the issue, and now I cannot. I do not know what changed between the 18th and today (it seems updates were installed), but the issue seems to be gone, now.
    Tuesday, August 30, 2016 2:04 PM
  • I'm having the same problem, but I'm not using an ENTRYPOINT. It seems to work fine over and over and then suddenly it starts having the described behavior (docker ps hangs, can't restart windows). Even after a power-off, the system never seems to go back to "normal".
    Tuesday, August 30, 2016 5:07 PM