locked
My 'Chrome Type' disappears when I click 'Apply', 'OK' then 'Exit Edit Mode' RRS feed

  • Question

  • I've got a Forms Library which is not being used correctly - due to the layout of the library. I'm trying to create webparts for each of the department forms (Dept = HR, Dept = Finance etc) so that when people visit the library they can quickly go to the webpart that contains the forms they are looking for. When I 'Exit Edit Mode' the webparts lose their titles and borders, even although I have went back into each of the webpart settings and ensured the Chrome Type is changed from 'None' (which appears to be the default) to 'Title and Border'.

    Any ideas? Thanks in advance,

    Krystall
    Tuesday, August 2, 2011 9:29 AM

Answers

  • Hi Krystall,

     

    I met the problem what you exactly describing when I test in my environment. Before I click “Exit edit mode”, everything works fine. But after clicking it, the settings just disappeared.

     

    You can open you SPD and right click on the webpart zone you created. Selecting “web part zone properties” to see if the Frame style is “Title Bar and Border”. Then creating a web part and setting its properties by right click. Please remember to create a new web part zone. It works for me.

     

    Hope this helps

     

    Thanks

    Pengyu Zhao

    • Marked as answer by Wayne Fan Friday, August 12, 2011 1:56 AM
    Wednesday, August 3, 2011 8:39 AM

All replies

  • Hi Krystall,

     

    Please try to add webparts with SPD(SharePoint Designer). This will keep the settings which you set in Chrome. You need to creat a new webpart zone first, then creat webparts in the zone.

     

    Here are two articles about how to insert webparts and webpart zone with SPD,

    http://office.microsoft.com/en-us/sharepoint-designer-help/insert-or-delete-a-web-part-HA010148720.aspx

    http://office.microsoft.com/en-us/sharepoint-designer-help/insert-or-delete-a-web-part-zone-HA010151394.aspx

     

     

    Thanks,

    Pengyu Zhao


    Wednesday, August 3, 2011 3:07 AM
  • Thank you for your reply, however, this does not solve my problem  :(

    When I am in 'Edit Mode' or in SharePoint Designer, the Titles and the borders are clearly shown around the webpart - its when I Exit or Publish the page that they disappear again and I am left with a list which has no headings or outline to divide the forms.

    Thanks

    Wednesday, August 3, 2011 7:55 AM
  • Hi Krystall,

     

    I met the problem what you exactly describing when I test in my environment. Before I click “Exit edit mode”, everything works fine. But after clicking it, the settings just disappeared.

     

    You can open you SPD and right click on the webpart zone you created. Selecting “web part zone properties” to see if the Frame style is “Title Bar and Border”. Then creating a web part and setting its properties by right click. Please remember to create a new web part zone. It works for me.

     

    Hope this helps

     

    Thanks

    Pengyu Zhao

    • Marked as answer by Wayne Fan Friday, August 12, 2011 1:56 AM
    Wednesday, August 3, 2011 8:39 AM