none
Timeout in BizTalk Admin Console When Querying Completed Instances RRS feed

  • Question

  • Hi there.

    Can anyone help me with this? I've spent a lot of time trawling the net but haven't been able to find a solution. I'm using BizTalk Server 2009 Standard Edition. I can perform "simple queries" against tracked service instances without any problems. For example:

    Search For Equals Tracked Service Instances
    State Equals Completed
    Maximum Matches Equals 50
    Service Class Equals Orchestration

    But if I try to run more complex queries, I invariable get the SQL timeout error shown below. I have tried to change the tracking query timeout interval by modifying the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\BizTalk Server\3.0\Tracking\ConnectionTimeout but this hasn't had any effect. Any help would be gratefully appreciated.

    Thanks,

    Mark



    TITLE: BizTalk Server 2009 Administration Console
    ------------------------------

    BizTalk Archive not available or not configured.  Verify BizTalk Archive on server XXX using  tracking database BizTalkDTADb is accessible and configured with a compatible version. (Microsoft.BizTalk.Administration.SnapIn)

    For help, click: http://go.microsoft.com/fwlink/?LinkId=47400&ProdName=Microsoft+BizTalk+Server+2009&ProdVer=3.8.368.0&EvtSrc=Microsoft.BizTalk.Administration.SnapIn.Properties.Errors&EvtID=ArchiveNotFound&EvtChain=MSSQLServer+%2c-2

    ------------------------------
    ADDITIONAL INFORMATION:

    Timeout expired.  The timeout period elapsed prior to completion of the operation or the server is not responding. (Microsoft SQL Server, Error: -2)

    Friday, August 5, 2011 11:31 PM

Answers

  • Maybe you are on 64-bit and the setting is under the Wow6432Node branch of the registry for you? So try setting the value at: HKEY_LOCAL_MACHINE\Software\Wow6432Node\Microsoft\BizTalk Server\3.0\Tracking\ConnectionTimeout

    Thanks,

     


    If this answers your question, please use the "Answer" button to say so | Ben Cline
    • Marked as answer by M Chappell Tuesday, August 16, 2011 12:47 AM
    Monday, August 15, 2011 6:20 PM
    Moderator

All replies

  • not sure if this will help or not, but have you tried looking at the event logs regarding the communication between your sql server and BizTalk Server? Also, have you tried refreshing the sql instances on your biztalk box?
    Ankit
    Saturday, August 6, 2011 1:21 AM
  • Sounds like you're on a test server? If so, try to change SQl timeout? (right-click server in sql management studio-> Properties-> Connections where "remote query timeout" is).

    Sunday, August 7, 2011 7:37 PM
  • Hi there. Thanks for the response. Yes have tried everything obvious. Everything else functions well. Even queries on completed instances work so long as they are simple and the timeout period isn't reached. I assume that there must be some config setting/registry entry but I haven't been able to find it.
    Wednesday, August 10, 2011 7:57 PM
  • Hi there and thanks for the suggestion.

    No, I'm not on a test server. The remote query timeout value is 10 minutes on the server, yet my BizTalk queries will timeout after about a minute, so it's clearly a BizTalk controlled setting.

    Wednesday, August 10, 2011 8:11 PM
  • Did you tried

    maximumMatches = 1

    ?

     

    Are you feeling any performance issue with this BizTalk server?


    Leonid Ganeline [BizTalk MVP] BizTalk: Sample: Context Routing and Throttling with orchestration
    Thursday, August 11, 2011 12:32 AM
    Moderator
  • Can you check the size of the BizTalkDTADB database. Is the 'DTA Purge and Archive (BizTalkDTADb) job' configured and running without any error?

    Don't forget to mark the post as answer or vote as helpful if it does, Regards -Rohit Sharma (http://rohitbiztalk.blogspot.com)
    Thursday, August 11, 2011 5:32 AM
    Moderator
  • Maybe you are on 64-bit and the setting is under the Wow6432Node branch of the registry for you? So try setting the value at: HKEY_LOCAL_MACHINE\Software\Wow6432Node\Microsoft\BizTalk Server\3.0\Tracking\ConnectionTimeout

    Thanks,

     


    If this answers your question, please use the "Answer" button to say so | Ben Cline
    • Marked as answer by M Chappell Tuesday, August 16, 2011 12:47 AM
    Monday, August 15, 2011 6:20 PM
    Moderator
  • Hi Ben.

     

    Yep, I'm on a 64 bit server. I tried your suggestion and it seems to have done the trick. Thank you very much indeed. If the Microsoft article on Technet I read (http://technet.microsoft.com/en-us/library/aa578005%28v=bts.70%29.aspx) had this information in it I'd have saved a heap of time.

    Thanks again and a big thanks to all the other good folk who took the time to help.

     

    Cheers,

     

    Mark


    Tuesday, August 16, 2011 12:46 AM
  • Mark,

    Awesome! It was a wild guess so I am glad it worked. I will add a community content comment to the article.

    Thanks,


    If this answers your question, please use the "Answer" button to say so | Ben Cline
    Tuesday, August 16, 2011 3:43 AM
    Moderator