none
Cannot delete an old azure classic alert RRS feed

  • Question

  • The alert has been deleted from the portal and is nowhere to be seen, yet still fires emails. When running "az monitor alert list" in the azure CLI it's still here with the original settings, shown as enabled. I tried to delete it via "az monitor alert delete" which seems to be successful (doesn't return any error), but when running "az monitor alert list" the alert rule is still here...


    Wednesday, May 8, 2019 10:12 AM

All replies

  • Hello, Julien!  Thank you for using Application Insights.

    First and foremost, Classic Alerts is going to be deprecated next month on June 30th, 2019:

    "Azure Monitor has now become a unified full stack monitoring service, which now supports ‘One Metric’ and ‘One Alerts’ across resources; for more information, see our blog post on new Azure Monitor.The new Azure monitoring and alerting platforms has been built to be faster, smarter, and extensible – keeping pace with the growing expanse of cloud computing and in-line with Microsoft Intelligent Cloud philosophy.

    With the new Azure monitoring and alerting platform in place, we will be retiring the "classic" monitoring and alerting platform - hosted within view classic alertssection of Azure alerts, will be deprecated by June 2019 in Azure public cloudsAzure Government cloud will not be affected.

    We encourage you to get started and recreate your alerts in the new platform. For customers who have a large number of alerts, we are rolling out in phases, a voluntary migration tool to move existing classic alerts to the new alerts system without disruption or added costs."

    Regarding what you are seeing though, I tried to reproduce this without any luck.  I created two classic alerts and deleted one in the portal and the other using the CLI, however both classic alerts were deleted from both the portal and the CLI, and I did not receive email notifications from either. 

    Try deleting the classic alert again and if you still are receiving email alerts, let us know so we can further troubleshoot this.


    Friday, May 10, 2019 9:58 PM
    Moderator
  • Hello,

    Thanks for your feedback. I tried again deleting the alert rule via the CLI and it's still here when I run a 'az monitor alert list' on the CLI. Looks like it's stuck in limbo...

    I'm aware of the deprecation of the azure classic alerts, hence why we started moving to the new alerts. This particular metric is now monitored by a new alert, much more finely tuned, but the problem is that we still also receive alerts from its predecessor from the classic alerts, which is pretty annoying/confusing.


    Monday, May 13, 2019 9:53 AM
  • Julien,

    That does sound confusing and annoying, and we do appreciate you migrating to the new alerts.  To further troubleshoot this, we'll need to get some information from you directly.  Please email the following to AzCommunity@microsoft.com and we'll get back to you promptly:

     

    • Your Subscription ID (this can be found by searching for "Subscriptions" in the portal)
    • A link to this thread so we can validate and expedite the request
    • A brief, 2-3 sentence summary of your issue
    • The person you were working with (kobulloc)

     

    That would look something like this:

     

    I was working with kobulloc on an Application Insights issue where we were unable to successfully delete classic alerts.

     

    Forum Link:

    https://social.msdn.microsoft.com/Forums/en-US/a5784cfe-1268-40f5-aa82-ece480ee8edc/cannot-delete-an-old-azure-classic-alert?forum=ApplicationInsights

     

    Subscription ID:

    aaaaaa-bbbb-cccc-1111-222222222222

    Monday, May 13, 2019 11:14 PM
    Moderator