none
Plug and Play driver Test" on WLK 1.5 - Run Remove PNPD Test failed RRS feed

  • Question

  • I had run the test for "Plug and Play driver Test" on WLK 1.5 as well for W2K8x64 and W2K8R2 x64 OS platform, and all are showed "RunJob - Plug and Play Driver Test - Library Job" failed. The error detail displayed as below:
       
    Context  
    Context Index:   487942041
    Current:   One instance of the device must be on the paging path
    Parent:   WTTLOG
    Start Test 1/20/2010 6:15:35.319 PM One instance of the device must be on the paging path
    Message 1/20/2010 6:15:35.319 PM Checking device "ROOT\MPIO\0005"
    Message 1/20/2010 6:15:35.319 PM Enumerating child devices.
    Message 1/20/2010 6:15:35.319 PM Pagefile was not found on "ROOT\MPIO\0005" or any child devices.
    Message 1/20/2010 6:15:35.319 PM ROOT\MPIO\0005 is not on the paging path, excluding
    End Test 1/20/2010 6:15:35.319 PM One instance of the device must be on the paging path
    Result:   Fail
    Repro:   Pagepath, Version=6.1.0.0, Culture=neutral, PublicKeyToken=null /device ROOT\MPIO\0005


    When view the child job result, click on the "Plug and Play Driver Test - Library Job" which is failed, 2 out of 13 task execution are failed:
    1. STORAGE: Detect if device is a boot/page parent adapter
    2. Run Remove PNPD Test

    I had tested the same test on WLK 1.4, and they all passed! Anyone could help in resolving this issue please? It's quite urgent!!

    Thanks.
    Friday, January 22, 2010 7:18 AM

All replies


  • Hi

    Download Windows Logo Kit: https://connect.microsoft.com/site/sitehome.aspx?SiteID=668

    Download WLK Help document: https://connect.microsoft.com/Downloads/Downloads.aspx?SiteID=668 and find the below document.

     

    Follow the directions as per the above help document for installation and setup… testing process…

     

    If you have any issues with kit installations, Test failures... Then you may need to open a case with WLK team. They will guide you on testing process.

     

    WLK Support from Microsoft:-


    Customer Support Services (CSS) provides technical support for Logo tests and tools. You must resolve any test failures before making a test submission.

    1.       Customers with Premier support contracts: Use your TAM to open support incidents.

    2.       For non-Premier customers: See Windows Logo Kit support.

     

     

    Reference Links:

    https://www.microsoft.com/whdc/winlogo/default.mspx

    https://www.microsoft.com/whdc/winlogo/getstart/default.mspx

    https://www.microsoft.com/whdc/winlogo/hwrequirements.mspx

    Omanakuttan M.K.

    Thursday, February 25, 2010 1:38 PM
  • please make sure you have two paths connected...
    Monday, March 22, 2010 5:48 AM
  • Thanks Omanakuttan M.K. and slee222. The issue had been resolved.
    Monday, April 5, 2010 8:32 AM
  • Hi WongKS, can you please share the solution with us? I Have similar problems. What is the actual message of "One instance of the device must be on the paging path"? Thanks for any help.

    Thursday, April 15, 2010 7:50 AM
  • Hi nulles,

    This is a known issue by Microsoft indeed. In order to generate the CPK file to show the "Plug and Play driver Test" has passed, you could download the latest WLK Updated Filters from the winqual site and install onto your WLK controller server before the CPK file is created.

    Cheers,

    WongKS 

    Tuesday, April 20, 2010 8:14 AM
  • Thank you WongKS,

    unfortunately the filter update did not resolve my problem, i.e. mark the test as passed in the cpk file.

    The pagepath.wtl log file reports "Pagefile was not found on [DEVICE] or any child devices."

    If I only knew what this message means. My device is not a storage device. I am running for Unclassified logo only.
    The DTM PnP Driver Test job does "STORAGE" tasks. Why?
    The Setup phase task "STORAGE: Detect if device is a boot/page parent adapter" fails with the pagefile error.
    The Regular phase tasks all fail with "Device node not found".

    Are the Setup phase tasks required to pass for the PnP job to pass?

    Tuesday, April 27, 2010 12:15 PM
  • Hi nulles,

    As for my case, the issue was happened when running the MS Logo certification test for the storage devices. I think probably you could report this issue to WLK support center by sending them an email. Hopefully they may help you on this.

     

    Cheers,

    WongKS

    Thursday, April 29, 2010 8:40 AM
  • >  please make sure you have two paths connected...

    Hi slee222,

    Why is this the issue? How to deal with if it is happened?

    Wednesday, August 4, 2010 4:08 PM
  • Hi Allen-Zhang,

     

    For your information, I had reported this "Plug and Play driver Test" on WLK 1.5 to Microsoft support team, and according to the support manager, this is known issue to Microsoft. In another word, Microsoft will approve your logo submission even this process (Plug and Play driver Test) is failed in your CPK file.

    Hopes this will help.

    Cheers,

    WongKS

    Monday, August 9, 2010 3:32 AM