locked
Plain text in french in a contentplaceholder RRS feed

  • Question

  • User-1860075769 posted

    I have some content text in french and when I publish it to my website all the special characters are stripped out. I don't know if it has anything to do with Localization and/or Internationalization. How do I have my french text preserved.

    Thanks

    Wednesday, July 26, 2006 10:55 AM

All replies

  • User-1936818034 posted

    If you can set your server' regional setting, check if it's french.

    Or try checking your files' encoding:  File -> Advanced Save Options

    And the <globalization/> section, try changing it's to the same with your server's settings. But usually utf-8 is okay.

    Wednesday, July 26, 2006 10:12 PM
  • User-1860075769 posted

    Thanks for the suggestion.

    Over the net I found :

    System.Threading.Thread.CurrentThread.CurrentCulture = New Globalization.CultureInfo("FR-FR")

    which I used in the page_load, but it did not work. Probably missing something. Pehaps it need a namespace ... but as I does not generate any error ...?

     

    However I also found:

    <META http-equiv="Content-Type" content="text/html; charset=iso-8859-1">

    which I used in a <script> </script> tag inside the declaration of the placeholder and It seems to work.

    Until next time

    sd

    Thursday, July 27, 2006 3:35 AM
  • User-1936818034 posted

    You may set culture info in InitializeCulture(), which overrides the page's base class's method of the same signature.

    But [;)] I don't think it's the reason for your problem, and there is a globalization section in web.config. Try checking or setting these 3 elements:

    requestEncoding="any valid encoding string"
    responseEncoding="any valid encoding string"
    fileEncoding="any valid encoding string"

    And for the meta data content-type, your can try setting the charset to the same encoding of your page, as I said it's in advanced save options of the file menu~ But of course usually some common encoding such as utf-8 or your iso-8859-1 there is preferred~

    Thursday, July 27, 2006 3:53 AM
  • User445179017 posted

    hi,

    you need to override the InitializeCultureInfo of your page, and its where you set the new culture info.

    Thanks

    Sunday, July 30, 2006 11:19 AM