locked
WebPerformance Test - in Visual Studio 2012 RC RRS feed

  • Question

  • I have installed Microsoft Visual Studio 2012 RC Edition and created a new Project for WebAndLoadPerformanceProject

    I created WebPerformaceTestand selected Add Recording

    It opened a new I.E browser and opened Google web site and recorded activities. When I stopped recording, it was not recording the activities

    I generated the coded but no coded related to above activities were recorded

    When I played back (Test: Run All Test) , The result was displayed passed but the there was no browser launched and no activities were recorded


    Friday, August 3, 2012 4:27 PM

Answers

All replies

  • Hi SriniTestAutomation,

    You can open your web test to check if there are some requests. If not, you are right that no coded related to activities are recorded.

    The link below is about how to create a ne web performance test using the web performance test recorder:

    http://msdn.microsoft.com/en-us/library/ms182539.aspx

    Thanks,

    Amanda

    Monday, August 6, 2012 2:42 AM
    Moderator
  • Thank you Amanda , but it didn’t worked for me. I have deleted the Cache, enabled the Web recorder in I.E Options as per the below blog sessions .

    I tried both in Visual Studio 2010 and 2012 RC . I have I.E 9.0

    I tried both with my intranet site and ‘google’ web site.  I also added these sites as trusted security sites http://blogs.msdn.com/b/mtaute/archive/2007/11/09/diagnosing-and-fixing-web-test-recorder-bar-issues.aspx
    http://social.msdn.microsoft.com/Forums/en-US/vstswebtest/thread/b952730c-04cb-4d52-959b-55a189bd51ac

    Also , I don't know why in my Registry settings, I don't see sub folder "Web and Load Test project"in 10_config folders   




    Tuesday, August 7, 2012 6:08 PM
  • Hi Srini,

    There are still some other good advice from Edwer you can try:

    http://social.msdn.microsoft.com/Forums/en-US/vstswebtest/thread/e0f8c0e8-8966-4e66-afbe-2bf9561bc125

    And you can check if there is some indication of a dll not being found or a missing registry entry or something like

    that, about this situation, you can see the thread below:

    http://social.msdn.microsoft.com/Forums/en-US/vstswebtest/thread/ccb91f34-bfd1-463d-8c04-2b772f4b37c4/

    I hope this can be helpful to you.


    Thanks,

    Amanda



    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, August 8, 2012 6:32 AM
    Moderator
  • Hi Srini,

    What about your issue now? Have you resolved it? If you have solved the issue, you can share your solutions & experience here. It will be very beneficial for other community members who have similar questions.

    Thanks,

    Amanda


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Friday, August 10, 2012 5:43 AM
    Moderator
  • Amanda , Thank you so much

    The below issue I reported while Clicking on "Stop" button of the Web Recorder has been resolved.  I was able to resolve with the help of the forums that you referred.

    "Unable to load DLL 'Microsoft.VisualStudio.QualityTools.RecorderBarBHO90.dll': The specified module could not be found"

    I copied the dll into the said directory but not registered those dll .

    I am able to record the web performance tests now but when I ran my script, it is failing in the below requests

    Issue #1.

    "An Add on for this web site failed to run. Check the security settings in I.E for potential conflicts"

    When I look at the details " response url" is passed  and in the response bytes , I see some data

    Can we ignore the above error as we are doing only the performance test not UI validation test ?

    Issue #2.

    I see "404- not found error for another request (see the screen shot) . Was it failing because of .xap file in the before request?

    Can we also ignore this error as I see some data in "response bytes" .  There is "0" bytes in request bytes for the first 4 bytes but I see some data after all the requests

    http://social.msdn.microsoft.com/Forums/getfile/150794

     

    Friday, August 10, 2012 4:43 PM
  • Hi Srini,

    For the issue #1, I would like to know the technology used on the page in the playback window when you see the error. If it is a plug-in like fresh or Silverlight, or an active X control, this could be the expected behavior. The playback window does not run javascript or active X so seeing this message does not necessarily mean there is anything wrong. So in my opinion, you can ignore it if you want.

    For the issue #2, 404 errors indicate that the server itself was found, but that the server was not able to retrieve the requested page. If you want to ignore this error, TL’s suggestions in the thread below may be useful:

    http://social.msdn.microsoft.com/Forums/en-US/vstswebtest/thread/6f8c641b-9d52-4886-974c-542687c20556

    Thanks,

    Amanda


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, August 13, 2012 1:53 AM
    Moderator