none
Workflow Manager with Project Server error Exception Starting Workflow: The value for column _WORKFLOW_INSTANCE_UID_ in table _WorkflowInstance_ is DBNull RRS feed

  • Question

  • Hello,

    The project server workflows were running fine on my servers (2 App and 2 WFE). suddenly workflows are not working anymore.

    and I am getting the below error:

    • DBNull.. Trace: at Microsoft.Office.Project.Server.Schema.WorkflowDataSet.WorkflowInstanceRow.get_WORKFLOW_INSTANCE_UID() at Microsoft.Office.Project.Server.BusinessLayer.Workflow.StartWorkflow(Guid projectGuid, Guid enterpriseProjectTypeUid, Boolean isNewProject, Guid previousEntepriseProjectTypeUid, Boolean skipStage, Guid stageToSkipTo):
      • WorkflowExceptionStartingWorkflow (35115). Details: id='35115' name='WorkflowExceptionStartingWorkflow' uid='047a6f2d-8a44-e411-8bf4-0050568b37eb'.

    I checked all DBs; all running fine. Also I tried to re-register the workflow with my site collection. but nothing worked.

    Any suggestions?


    Twitter : @MShoubaki | http://jo.linkedin.com/in/mshoubaki

    Thursday, September 25, 2014 8:39 AM

Answers

All replies

  • Any chance you installed any updates recently?  I just started to get this error this afternoon and there were problems installing Windows Updates (SharePoint) this morning.  

    I am running SharePoint & Project Server 2013.  

    Friday, September 26, 2014 5:51 PM
  • I upgraded to SP1 last week, but not sure if it is the reason.

    Twitter : @MShoubaki | http://jo.linkedin.com/in/mshoubaki

    • Proposed as answer by A Bauman Tuesday, September 30, 2014 3:16 PM
    • Unproposed as answer by A Bauman Tuesday, September 30, 2014 3:16 PM
    Saturday, September 27, 2014 3:57 PM
  • Were you able to process any workflows after the upgrade?  I think it is related to patches that I am having the issue.  
    Monday, September 29, 2014 1:05 PM
  • Hi Mohammad, 

    I was able to resolve my issue by installing KB2880963.  I did not have any of the other updates mentioned installed, but it did resolve the issue. 

    Note: I did need to restart my servers.  

    See Below from
    http://social.technet.microsoft.com/Forums/windowsserver/en-US/b189e4b8-bb9e-4ade-a3d5-cd2e0f90e93f/workflow-not-working-after-installing-service-pack-1-and-patches?forum=sharepointadmin 

    Here is the security update which you will need to install.

    Update 2880963 for SharePoint Server 2013

    http://support.microsoft.com/kb/2880963

    Chcek the link for details.

    http://expertsharepoint.blogspot.de/2014/08/workflow-not-working-after-installing.html

    • Proposed as answer by A Bauman Tuesday, September 30, 2014 3:18 PM
    • Marked as answer by Mohammad Shobaki Sunday, October 26, 2014 7:08 AM
    Tuesday, September 30, 2014 3:18 PM
  • Update 2880963 fixed the issue... but what I don't understand, that my SharePoint 2013 & Project Server 2013 where completely updated with all available Downloads (until June 2016).

    Do not forget to launch the "SharePoint 2013 Products Configuration Wizard", after "success" I restarted the Server and now the "2013-Project Server" Workflows are starting.


    Dirk

    Wednesday, June 24, 2015 3:39 PM